Compass not calibrated?

I have a Pixhawk with Arducopter 3.2.1 and a gy-271 external compass.
I’ve done calibration trough Mission Planner, it does calibrate only the primary compass (external?), so I had to put offsets for secondary compass manually to get similar measurements.
Any idea on why prearm check still fail saying “Prearm: Compass not calibrated”?

I had this as well, confused the hell out of me.
Change those manually entered values back to 0’s and it will probably work, did for me.

But what’s the use of an uncalibrated compass?
Wouldn’t it be better to just disable the check?
If I do the copter flyes well, but I want to understand why the warning appears, to be sure there is no problems in my configuration.
Maybe is something related to orientation? What AHRS_ORIENTATION and COMPASS_ORIENTATION do you use?


The compass values are for the internal compass and as I use an external it’s not worried me about them being 0’d. Certainly hasn’t affected the flight characteristics in any way that I could see.

Can someone explain what does it check to say if compass is calibrated or not? I have not set declination and motor compensation, might be that?

I tought about orientation because I have pixhawk flipped on long axis, so AHRS_ORIENTATION 8. Accordingly to axis printed on compass module’s pcb the correct COMPASS_ORIENT should be 4 (to make axis coincide with frame axis) or 12 (to make axis coincide with PH axis). But I have to set 2 to have correct readings, and had to set 0 with 3.2rc, so I’m a bit confused…

Tried motor compensation calibration, prearm fails
Tried secondary compass offsets to 0, prearm fails

I don’t think this will help, but on my new Iris+, when connected to “mission planner” and compass calibration, I get 2 globes showing, one for each compass :wink:

I see only one globe…
I tried last stable and last beta mission planner with arducopter 3.2.1 and 3.2rc10, I also tried apm planner 2
Motor comp calibration worked for both compasses tough, but I didn’t see any line in the graph when calibrating

Seems like I get both globes if I connect through usb, couldn’t complete calibration tough, my cable is too short :confused:

I normally connect mission planner trough tcp, trough mavlink hub on my smartphone trough bluetooth at 115200bps to telemetry port 2. May this be a problem?