Servers by jDrones

Compass inconsistent error after previous calibration

I was having an issue today at the flight field with the compasses not calibrating and giving the error “compass inconsistent” when attempting to arm the airplane. This happened after a previous calibration which resulted in good compass health, no excessively high offsets, and a reasonable compass reading (~5-10 degrees off). I’ve flown this way in the past with simpler setups and allowed for the compass to learn and realign in the air but we need a reliable calibration on the ground that can be replicated. Both calibrations were completed using “Live calibration” and all 3 compasses were updating and data points were centered around the shown axes. We tried multiple different calibrations and went to the middle of the field to not be surrounded by electronics. Additionally, we tried using the COMPASS_LEARN = 2 for EKF learning and drove the airplane around on the ground to update offsets, disarmed, power cycled and still had this issue. Does anyone have a fix for this issue, or have had troubles in the past with calibrations not staying accurate to the airplane and needing to be repeated directly before every flight? Also, any idea why “Large vehicle calibration” won’t work, I can put in the heading but the “Command Failed to Execute” issue always pops up.

Thanks in advance!!

Servers by jDrones