Communication error - no connection... Aarrgghhhhhhh

Hi, this one has me beat and a little frustrated… Any tips greatly received !

Previously running Mission Planner 1.2.38 with the arducopter quad firmware installed… Worked great and Encountered no probs when I originally updated the firmware earlier last yr…

I’ve now decided to try the apm 2.5 board in my plane for a new challenge… Everything stripped out of the quad and have the apm 2.5 hooked up to the PC on my desk. Updated mission planner to 1.3.0 and currently attempting to flash the board with Arduplane 3.0.1.

The mav link connection works fine but when I disconnect and try to update the firmware to the Arduplane I always get the dreaded “communication error -no connection” whilst in the “Reading Hex” stage… And the upload fails…

Checked all the usual stuff… Baud rate set correctly ( on the port and in mp), tried different USB ports, USB cables, powering the apm separately, uninstalled and reinstalled mission planner, I’m now kinda stuck what to try next… Any suggestions would be most welcome !!

Thanks in advance
Best Regards

Hi… I fixed it !!! Having exhausted every avenue I could think of I disabled the other ports in device manager which were not being used by the MP. And hey presto the firmware uploaded.

Amazing how something so simple cost me half a day messing about :slight_smile:. Oh well…

Hope this helps some one else !!

Speak later

Wow this saved me a lot of time!!! Thanks :smiley:

Yessss!!! Fixed the same problem for me :slight_smile:

When reading it I didn’t thought it will do anything but - decided to give it a try…
Well … Your gut it right. It does solve the problem

:slight_smile: Gil

Can somebody please explain to me how to disable the ports in device manager do you mean the usb ports? help please I keep getting the communication error!!! its so frustrating. thank you.