Check BRD error?

Hi Friends,
I updated the Pixhawk on my Quad to Copter 4.0 and now I get this Error “Check BRD_TYPE: Failed to update IO firmware”. It had been flying fine. I’ve loaded several different firmware and no go. BRD TYPE is set to 2 for Pixhawk. Any Ideas???

My guess is that for some reason during your last update, the iomcu firmware didn’t update properly.
Two options: flash the firmware again (you may have to force that, depending on your gcs), or hold down the safety switch whilst you power up the pixhawk.
Either method should trigger the main firmware to update the iomcu.


Thanks James, I have flashed the firmware several times. I’ll try the safety switch.

Some FC just don’t have an IO processor. if you flash the wrong firmware, you will get this error

Thanks for the reply,
This is one of the first Chinese Pixhawk clones, I’ve been flying it for so long I don’t remember when I bought it. It has been on a Boat, A Rover, a Plane and many quads. I get bored and tear everything apart and rebuild it into something else. I don’t remember which version of the firmware I was flying for the last few years. Upgrading to Copter 4.0 is the first I’ve seen this error.

Perhaps it’s one with 1M flash. Try downloading the APJ from here and do a custom firmware load.

I tried loading this firmware. It gives me the same error.
I’m wondering about the ChiBios, should I have installed it.
I did.

Which Pixhawk is this? Yes, Chibios is what you wan’t. You could give QGrounControl a try. Install latest Stable Copter Chibios. Then after a power cycle connect to Mission Planner.

Mission Planner says it is an PX4V2

Yes, but which piece of hardware? There are a lot of Flight Controllers called “Pixhawk”

On the board is "PX4FMU 2.4 © 2013
I can’t remember where I bought it, from “Witespy RTFhawk” or GoodLuckBuy under some name, Pix something.
That’s all I know.