Channel binding confused with Spektrum Satellite Receiver

I’m putting together a new Hexacopter with the Pixhawk, 3.2RC14 of the firmware and a Spektrum DX7 and Spektrum Satellite Receiver similar to this setup: … ektrum_dsm

My transmitter is able to communicate with the receiver and I can interact with the Mission Planner R/C calibration screen successfully.

The problem I’m having is that the channels and controls are mixed up as follows:

1.) The left throttle controls the pitch channel rather than throttle

2.) The right pitch control controls the throttle channel rather than pitch

3.) The left yaw control activates the correct yaw channel but is 180 degrees in the wrong direction

4.) The right roll control activates the correct roll channel but is also 180 degrees in the wrong direction

5.) The Aux 2 toggle seems bound to the Radio 7 channel rather than the Gear Toggle

6.) The Gear toggle is bound to Radio 5 channel

7.) The left hold/rudder toggle is not bound to any channel

8.) The right flight mode toggle is bound to channel 6 rather than channel 5

Is the Ground Control station bind process necessary for the Pixhawk? I tried connecting the latest version of the GCS, but it will not communicate successfully with my Pixhawk with the 3.2RC14 firmware. Both the Mission Planner and APM 2 work fine.

Any ideas why the bindings are so confused?



Update: I reversed the roll and yaw controls using the Spektrum R/C settings, but I haven’t found a way to switch throttle and pitch yet. I tried changing RCMAP_THROTTLE to 2 and RCMAP_PITCH to 3, but that didn’t change the mapping for some reason.

Its almost like some part of the system is assuming I have a mode 1 R/C rather than a mode 2. But the R/C transmitter is setup as mode 2. (Throttle on left.)

I followed these instructions: … t%3A637661

to get the toggle buttons to work together to specify 6 modes. This procedure enabled the left rudder toggle, but the rudder and flt mode toggles still are tied to channel 6 rather than 5. The firmware expects channel 5 to control the flight modes.

I got the throttle and pitch reversed by remapping the channels to these settings:

Now I just need to figure out how to get channel 6 mapped to 5.

Looks like the settings above were wrong. After restarting the Pixhawk and Mission Planner, I needed to change the settings to these for the 4 main controls: