Servers by jDrones

Changing securtiy (Auth) type to WPA2?

(Andy B23) #1

Hi,

Our drone is using a RPI3+ with APSync. The AP gets created and i can connect to it and open the configurations page @ http://10.0.1.128/apsync/system.html . Everything is working fine so far.

Changing the Auth Type there to any option does not work. It always stays WPA. I also tried to change it via command line an nmcli but there i just can use wpa-psk for the key-mgmt.

My goal is to connect a Tello EDU drone to the AP from my bigger drone. The bigger drone should act as kind of mothership which controls a little swarm around itself. If i use another AP (for example when i use the hotspot from my cellphone which uses WPA2-Auth), the Tello EDU is connecting to that AP. I believe, that the Tello EDU is not able to connect to the APSync AP because it requieres WPA2 Auth.

Thanks for any help

(Andy B23) #2

Solution
Setting the “proto” attribute to RSN did the trick.

  • sudo nmcli connection edit [name]
  • goto wifi-sec
  • set roto
  • rsn
  • save
  • quit

wpa-proto:
“RSN” = WPA(2)
“WPA” = WPA(1)