Servers by jDrones

Changing Flight mode at power up


(tucuman79) #1

Hi, I search in the forum but i couldn’t find a solution for an issue. When I power up my Pixhawk 2.1 it starts in RTL mode and servos moves continuously, I like to startup my plane with the radio control turned off and wait until it gets gps signal. Is there a way to startup in manual mode or other mode? thank you!


(Hunt0r) #2

Something sounds strange to me. If you power on, but your safety switch has not been pressed, the servos should not move. Have you disabled the safety switch?


(tucuman79) #3

Yes, the safety switch is disable because I also must arm the plane with the radio control, for me this is safe enough. So is the safety switch which enables RTL? is it possible to change the mode?


(Hunt0r) #4

Have you looked at the INITIAL_MODE parameter?


(tucuman79) #5

This parameter is in 0=manual, I changed to 5=FBWA and 4=AUTO but always start in RTL. I also reiniciate Mission Planner and the Pixhawk, but always starts in RTL.


(Hunt0r) #6

What are your Failsafe settings?


(tucuman79) #7

Here I send you my screen captures.

acap1


(Hunt0r) #8

As a test, change your FS_LONG_ACTN to 0. Then see if the problem continues?


(Joe Breznai) #9

@tucuman79
FYI: One should NEVER power up a RC receiver without the Transmitter ON. I have scars to prove it.
One RF spike can do crazy things and it can come from anywhere.
5 minutes to get GPS lock isn’t going to drain battery in any noticeable amount.


(tucuman79) #10

Yes, you are right, thank you for you advice. I was used to wait more 10 minutes to get GPS lock with my older FPV equipment, but now with Pixhawk you have radio arming and safety switch features to prevent motor start. Indeed I also have two planes and in this case I always turn on the radio control in first place.


(tucuman79) #12

I’ve changed FS_LONG_ACTN to 0 but nothing happens. This is the messages tab, this might be helpful.

M1


(Hunt0r) #13

Read the documentation about how FailSafes work, I think that will help you.