Changed behavior of Spline waypoint

Dear all,

While I test the spline waypoint, I notice that paths of spline waypoint is the same as normal waypoint on current master version.

When I run the mission in the above, the master version shows the straight paths as shown in the below.

On the other hand, when I run the same mission on ArduCopter V4.1.0-dev, it shows correct spline paths as shown in the below.

Is this already known issue?

You could reproduce the issue for the following steps:

  1. ./Tools/autotest/ -v ArduCopter --console -w --speedup=10 -L Karuizawa
  2. upload the mission (I have attached)
  3. param set RTL_ALT_TYPE 1

Edit: It seems that using different altitude frame is the key to trigger this issue. For example, if MAV_CMD_NAV_WAYPOINT uses relative altitude , leveraging MAV_CMD_NAV_SPLINE_WAYPOINT with terrain altitude leads to this issue.


So the 4.1.0-dev version you’re testing with is from June 2020 (so about 14 months ago) and you’ve uncovered a change in behaviour between 4.0 and 4.1. The change is that in 4.1 when the altitude type changes, the vehicle will always stop at the waypoint. I think you’ll find that if you keep the altitude types consistent for commands 6 and 7 it will fly the spline curve.

FYI @Leonardthall