Cant update pixhawk

Hey total noob here. Got a lend of an old 3dr iris+ drone from a friend. Trying to update firmware on mission planner and failing. Can connect the board to mission planner on com 3, it recognizes it as quadcopter and even gives a prompt that the firmware is out of date. When i disconnect to update the firmware it scans comports but says no heart beat found. Will updating the bootloader fix this problem?

Good day, do you have the last MP version?
Just try the option mandatory firmware… and select fmv3…

Ive tried that. It gets to scan comports then says failed to read board. Yet can connect to board in mavlink

You can go into windows device manager and set all the COM ports to 115k baud as the default instead of 9600.
If that doesn’t work try doing the update from QGroundControl, it will probably work.

1 Like

you can try also in this way, just download the firmware and install it using the option custom firmware

1 Like

I had a similar issue: you could try to use QGroundControl to update the firmware.
the other thing wich worked for me was to use the option: force Bootloader (But you should use it only if nothing else works).

Will updating the bootloader fix this problem

I have no idea but it could be the problem but it doesn’t need to be (I would just try to update it)

1 Like