Cant`t change from Quadcop to Hexacop in MP setup

Hi, im just finished installing MP setup on APM 2.8 on my Hexacopter.
It arms and only motor 1,2,3,4 work, 2 last one not moving. Connections controlled and works when i put engine 5- 6 in any other channel 1 to 4.

Have resetet several times with same result, only 4 of 6 motors runs.
On MP top right side stands COM6-1-QUADROTOR when i re write Hexa it wont stay…

Can anyone please help me, i`m not very experienced in programming.


Have you tried setting frame class in the full parameter list? Mission Planner has something wonky with the Wizard or mandatory hardware tab on frame types IMO.

Hi Matt , thank you for quick responce, i have now - i write 4 and it jumps
back to 2 when i press save.

Ive also tried to do the install with APM planner, same result 4 motors spinning, must be some issue with my APM - im stuck now .
Shall check more on web. :slight_smile: Thanks for your help.

You can verify in the documentation that your version of arducopter (3.2.1) is an ““old”” one not compatible with frame changing, due to old APM hardware. You have to upload the hexacopter version…


You are probably right, i got an old version . Where do i upload the
hexacopter version from ?


Not easy, I had to search the Wiki,

There is a .zip archive

Once expanded you choose the Hexa one and do a custom installation with Mission Planner


Amazing! i`ll try to install it - THANKS :slight_smile:


You can just select the current stable version of Hexa from the Mission Planner Install Firmware screen. It will recognize the hardware and install the last version that is supported.

Yep. Its obvious the OP had the quadcopter firmware installed…

Im not a experienced programmer , cant get trough…
Think i buy a new apm with upgraded firmware. Thank you so much for your
effort very much priciated.


I have tryed your solution unsucsessfully ,i`m not a very experienced
programmer so i will buy an upgraded apm 2.8
have spent to many hours to get trough mission impossible :slight_smile:


Don’t buy any APM they are obsolete. Buy a Pixhawk or Pixhawk variant.

Thanks Dave for tip , ill do that😊