Can't Install Firmware on New Pixhawk

When I plug in my Pixhawk the following happens

I get the device connection tones in windows
[li]FMU PWR light is ON[/li]
[li]FMU B/E light is blinking[/li]
[li]IO PWR is ON[/li]
[li]IO B/E light is ON[/li]
[li]IO ACT light is blinking[/li]
[li]button is blinking red[/li][/ul]
after a few seconds I hear the device disconnect tones in windows just before the the FMU B/E light turns off
then I hear the Start up OK sound from the pixhawk.
Towards the end of the pixhawk sound windows chimes in with its device connections tones.

In Mission planner i go to Initial Setup > install firmware > AdruCopter v3.2.1 Y6 (I have tried others as well)
MP then downloads the firmware, then reads the Hex file. It the tells me to unplug, press OK then plug back in. MP now displays “Connecting”. The pixhawk meanwhile boots up exactly as before (see above). After waiting for a bit MP pops up and Error: “Error uploading firmware” and in the actual window “ERROR: No Response from board”

I have tried the following already:
[ul][li]Reinstalled MP including uninstalling drivers[/li]
[li] tried using APM Planner2[/li]
[li] tried using px4uploader.exe directly[/li]
[li] tried different USB ports,cables, and computers[/li]
[li] I unhooked everything except the speaker and the button from the pixhawk[/li]
[li] took out and reformated the microSD card[/li][/ul]

I am not sure what else I should try at this point. any help would be greatly appreciated.

I have attached the MP log file from my last attempt

Have you installed the 3DR USB drivers? … sb-driver/

In the upper right corner on MP there is a drop-down list to select which USB port to use. You should see a port listed that displays a PX4 (?) in the description. Use that port. (Auto never worked for me.)

I have done both still the same result

When it says to unplug, press OK then plug back in, try this instead:
Reset the Pixhawk by inserting a very small screwdriver through the reset hole on the side of the Pixhawk where the USB connector is located then press OK.

That worked :smiley: :smiley: :smiley: :smiley: