Cant get the rover to go backwards

I set up my rover and everything seems ok except one issue; i cant get it to go backwards when using the RC remote. I can get it to turn left or right. I can get it to go forwards, but no backwards. The car itself is fine because it works when not attached to the 3dr computer.

in mission control, when i try to go backwards i see in “radio calibration” and “failsafe” that the throttle will go lower from its neutral position.

What am i missing?

Are you using a rover with a reversible ESC? The regular ones for copters/planes don’t go backwards. You need the special kind for cars.

He stated that it worked okay when attached to just the R/C receiver which would indicate that the ESC can be reversed.
This is indeed very strange in that the Radio Cal indication is that the throttle output can go below 1500us which is neutral for an ESC with both forward (>1500us) and reverse (<1500us).
@ultrarelativistic, are the above statements correct?

yes, those are all true statements. According to ‘radio calibration’ idel is 1373, reverse is 988, forward is 1591.

I would have expected neutral closer to 1500us. 1373us is really considered to be in the reverse range.
1591us is a very small change for the forward direction. Does it go very fast in the forward direction?
998 for the end of reverse is okay.

I use Traxxas ESCs in my Slash 4WD ArduRovers and here is how my throttle (elevator) channel is calibrated:
Max, 1930us (forward)
Min, 1082us (reverse)
Trim, 1500us (neutral/idle)

I think that your problem is that idle (neutral) is at 1373us which is about 127us into the reverse range.
I assume that you are using the elevator joystick channel for forward and reverse?

ok, figured it out. re-binded transmitter to ecs and it works now. weird. thanks for the help!