Can't get the compass z to calibrate below 190

I went ahead and bought the external compass and gps per suggestion for upgrading my 2.5 board. I’ve cut the trace and I’ve upgraded the fw to 3.1. I try to do the live compass calibration inside or outside but cannot get the “z” axis to drop below 190. The other two axis are within the 150 range. I’ve posted to the groups but haven’t had any response. The x axis is around -44 and the y axis is around + 20 but the z varies between + 190 to + 215. I can’t arm the apm either. I’m thinking it’s because the z value is above 150.

Can anyone suggest why this is happening?



Try changing the position of the compass, e.g. put in on a pole.

It is on a post now abt 3 inches up.

Hmm, check the position of the compass if there’s any ferromagnetic metal or magnets close. Any cables which lead power. Any big metallic objects close to the calibration place? Powerlines? E.g. if my old TV set is on, the magnetic field penetrates the outer wall and influences my compass module even 2-3m away in the garden.

I’ve tried it in the house outside the house in a park near the beach with nothing around it. I’m perplexed by it. I can get the z value to go higher. Just not below 190.

I’ve tried disconnecting everything from the apm. All that is connected is the gps, compass and USB cable. Still no change. I tried different positions of the gps antenna, spiraled the wires on the gps/compass. Tried a ferrite core on the wires.
Still no difference.

Could this be a bad compass/ GPS?

I’ve tried it in the house outside the house in a park near the beach with nothing around it. I’m perplexed by it. I can get the z value to go higher. Just not below 190.[/quote]

Ok, I finally figured it out after hours of trying everything possible to get the Z axis to calibrate within the range of + - 150. I was getting numbers in the + 190s and higher. In the end it was pretty simple. I watched the YouTube vids, I read and re-read the instructions multiple times but I couldn’t get it.

What I finally did was to setup the the netbook to “live calibration” hit start then held the FW 550 on its left side vertically. I held it there for about 15 seconds. Then moved to the front side held it vertical for abt 15 seconds and repeated for the last two axis. Interestingly, I had less data points than all other attempts but the end result was very good. My Z axis was in the +50 range. The X and Y axis were also quite low. Compass mot was 4%.

Looks like I was over thinking the process.

So the take away lesson here is to pause between each rotation of the APM during calibration?

=> … ss_offsets


That’s what I did and it worked great.

=> … ss_offsets


Believe me, I did this so many times. It still would not drop below 190 on the Z axis.
His advantage was that he isn’t connected by wires and having to carry a netbook around during his dance.

Ehm, netbook? Those things create quite a bit of EMI and so does the USB cable, especially when it’s powering the APM. Maybe you should try to get your hands on a set of radios and do the calibration againg. I’m sure, the results would be better. Alternatively, you could fly around for a while in stabilize with activated logging and then try to calibrate from logs.

Sent from my Ainol Novo 7 Fire using Tapatalk