Can't calibrate ESC with APM

i have some trouble to fly my quad after updating the board from a kk2 (that worked fine) to an apm.
For now i am only interested to the altHold function that is the reason of the upgrade.
i got 2 trouble but one is a blocking one.

First the lesser problem is that the compass doesn’t work. on mission planner the calibration gives error 99. As a quick fix i disabled it in mission planer, that will do for now.

The [size=150]big[/size] problem :
I can’t get the ESC to work properly.

  1. If i just plug everything and turn on control and then then plug battery, the esc keep beeping fast.

2)If i enter ESC programation mode ( throtle up, turn on APM turn off APM turn it on again), i successfully ear the melody meaning that all the 4 ESC enter programation mode. That mean that some signal goes through the APM to the esc.
But then turning the throttle down doesn’t do anything so i can’t calibrate them.
I have try to use the offset button on the controller to lower as much as i can my throttle signal, no success.

  1. In mission planer. I calibrated my RC successfully ( i can see radio 1,2,3,4 7,8 ).

  2. I have done the ESC programation after this calibration, same problem.

  3. In mission planner i changed the minimum throttle to 0 (instead of 130), no effect.

  4. In the failsafe screen i can see the servo/out channel and i notice that when my throttle is at 1069 minimum, the servo/out is around 1130 when armed ( 1069 unarmed), which might be the cause but i am still not sure.

  5. I can program the esc Individually straight from the receiver (motor can spin that way): The ESC works fine. The ESC calibrated this way behave the same as the other after reconnecting to the APM
    this mean that on start of the apm board, the esc receive something higher than it should be.
    After unpluging this ESC from the receiver, throttle down, APM disarmed and plug it on the board which was connected to usb, the motor start spinning comfirming that this signal is too high…

  6. I tried some trick that didn’t work either :
    Arm the board (while in usb) throttle high, plug battery ( esc enter programming) Lower throttle (ESC stay in programming) …

  7. After a day searching i hear thoose beep beep even when i am 1km away from them!

My ESC is turnigy plush 30A
board is APM 2.5.
I only have my ESC / receiver plugged to the APM

ALL i can find with google looks like some simple calibration problem :frowning:
I do not know what to do anymore

So after a few test with my voltmeter
On the receiver the signal goes from 0.02 to 0.3v and the esc work
BUT on the board the signal goes from 2.56v to 4.5v.
Why is that? is it normal?

Sooo i did some investigation to understand my problem and here is an interesting clue

In red is the signal out of the receiver.
In green the signal out of arducopter.

The frequencies of the green signal ( env 2ms) is 10 time higher than the red ( env 20ms ).
Is that normal, can i control this frequencies to get the same as the red one?

Next i will do the same with the KK2 board to compare
I will try to arm the board and see if the green signal goes larger when i push the throttle ( the red does)