Can't arm my quad after setupwizard(Pixhawk 2.4.8)

Hello there,

It’s been quite some time I’ve been struggling with this but when ever I try to arm my quad after hitting the safety switch(and doing all the appropriate calibrations the Quad wont get into arm (even at ACRO mode which doesn’t requaire GPS lock.

Not sure what it is I suspect it’s something with the ESC calibration but when I did that manually kindoff with the pixhawk it allowed me to spin them with the radio.

Any way I can see more clearly why it doesn’t arm?

I think the terminal might help but when I connect to it with the pixhawk it pushes gibrish to my display and I think it’s something with the baud rate as well.

Thanks for helping.

You have provided very little information to go on.
When asking for support you will need to supply a .bin file from the flight controller (log file)

Have you connected to Mission Planner? You just said terminal, what terminal?
Screen shot would help.

What colour LED flashes do you get?
Have you read through the Wiki?
What firmware have you loaded?

Details please

Actually not sure of what info would be useful for that sins I’m quite a noobie here now I don’t understand how a log file would help sins I don’t know what info it contains or how to generate it.

Talked about the terminal in mission planner.

I’ve read through wiki yes,

The led flashes yellow but after setting ARM_CHECK parameter to 0 it flashes blue can get it to arm but no loiter mode
The latest one as for now.

And the current GPS module is “Ready to sky”

What info were you hoping to see in the terminal?

If you are hooked up to Mission Planner then the Flight Data tab should display a message when you try to arm telling you what is wrong.
Do not set Arm_Check to 0. Arming checks are there for a reason.
If the brake warning light was on in your car would you just remove the bulb and try to drive it anyway?

You need to spend a bit more time going through the Wiki.
All the information you need is there.

When you ask for help here you need to include the log file so we can see what is going on.
In your case where it won’t arm you need to set the parameter for pre-arm logs.

I was hoping to see something that says if the GPS status is OK or shows errors.

Now I’ve been looking for the source of the problem for too long that’s why I’ve came here to ask for help.

Generally I’ve overcome the arm pre checks by now but still can’t use PosHold mode because of 3D fix problem

Couldn’t find a fix for it in the wiki page.


The log file is stored on the SD card in the pixhawk controller. You can either transfer to your PC via telemtrie or take out the SD card and use a card reader on your PC. The log file (.bin) shows us a lot of details about your software config and parameters. But normally it is only written once you have armed - see earlier comment.

But I’d go back a step if I were you - have you managed to arm/fly in stabilize mode?

I’d start with that very simple flight mode, once you get to arm AND fly in stabilize then try althold (arm & fly), then poshold and only then loiter/auto.

It’s hard to say what your issue is without the log and a better description, but I’d also fix all the PreArm check errors first (instead of disabling) - once you get those basics out of the way you might have also solved the arming issues…

Just a thought,