Servers by jDrones

Cannot trigger camera in plane

(plusmartin) #1


I cannot trigger the camera nor detect any feedback pin.
I have already configured RC10_FUNCTION = 10 (camera trigger), alsto tried using 0 and tried other aux channels.

Cable and camera work ok in my copter but not in my plane.
Mission planner says at the bottom of the gimbal setup that I must set the Ch7 Option to Camera Trigger, what does that mean and how do I do it?
There is no CH7_OPT parameter.


(Nicholas) #2

Try to switch off your safety switch and then attempt to trigger for your plane. It should work.

For me, i usually toggle my safety switch and then test my trigger during preflight.

And yes, i don’t have to do this in copter.

Camera triggering problem!
(Markus Müller) #3

In ‘Config/Tuning’ -> Planner -> Layout -> Advanced

Extended Tuning -> ch7 option or Full Parameter List/Tree search for ch7 etc.
Maybe you like to set BRD_SAFETY_MASK.

(Graham D) #4

There is no CH7_OPT parameter for fixed wing, that option is only available on 'Copter.

plusmartin, did you get this sorted?

(Graham D) #5

Also note that on new versions of the firmware the channel designation has changed, RC7_FUNCTION is now SERVO7_FUNCTION, etc, etc.

(plusmartin) #6

Hi @Graham_Dyer

yes I did solve the issue.
I configured SERVO11_FUNCTION = 10 (camera trigger) . Im using plane v.3.8.
in the gimbal settings make sure you have selected “servo” and the appropriate limits (1000min, 2000max, 1000 trim in my case)

very important and annoying: press the safety switch.