Cannot configure baud rate for GPS in ardurover

I am running ardurover (title bar says "Mission Planner 1.3.77 build 1.3.8110.38294 ArduRover V4.4.0-dev (650e8652) on a Beaglebone Blue with Linux 5.10.140-bone-rt-r68. I have a GPS connected to the GPS connector, and I can see NMEA sentences when I stop ardurover and use minicom on /dev/ttyS2 at 9600 baud.


However, Mission Planner always says no GPS. I’ve set the rates up for all ports except SERIAL0 to be SERIALX_BAUD: 9 and SERIALX_PROTOCOL: 5 (and OPTIONS: 0). I’ve restarted Ardurover and the entire board.

This is how it is being launched using systemctl:

SERIAL0="-A udp:"
SERIAL1="-C /dev/ttyS1"
SERIAL3="-B /dev/ttyS2"

/usr/bin/ardupilot/ardurover $SERIAL0 $SERIAL1 $SERIAL3

What am I missing?