Cannot access settings for telemetry


We purchased the telemetry kit from the 3DR website and we are trying to use it with our tricopter. We connected the ground module to a Windows 8
laptop and the air module is connected to the ardupilot mega 2.5 control board. When the control board is powered through battery, both the air and
ground module have solid green LED. When we try to configure the settings in the Mission Planner software, We get a number of errors. First when we
set the COM port to the port that the ground module is in, the connection times out when we click connect. We tried doing this with all of the baud
rates listed. When we click on the Load Settings button, we get an error that says Failed to enter command mode. When we click on the Upload
Firmware (Local) button, we get an error that says Failed to Identify Radio. The remembe telemetry works perfectly when connected to my phone and Droidplanner app. We would appreciate any help we could get.

I am using both the older and the newer 3DR telemetry radios with a Windows 8 laptop and have not had a problem communicating with the radios.
What version of the MP are you using.
Can you communicate with your APM using the USB connection?
What frequency version of the radios are you using? 914MHz or 433MHz?
Are they the newer radios in the plastic cases or the older ones in the shrink wrap?
The baud rate for the ground radio should be 57.6K.
Since both modules have solid green leds, they are communicating with each other.
You might want to work with just the ground radio for a start.
Before you plug it in to your PC, open the Control Panel, select the Device Manager, then plug in the radio to the PC USB port.
You should then see Ports (COM & LPT) appear.
Double click on the Ports and it should show you the COM port the radio has been assigned.
Is it the same port that appears in the MP? It should be, if not then you have a problem.
Close the Device Manager and the Control Panel and open the MP.
Turn on the aircraft radio and make sure both radios have a green led.
Go to the Initial Setup, Mandatory Hardware and select the 3DR radios.
Does the COM port seen in the Device Manager appear in the MP COM port window. If so, set the baud rate to 57.6K and try to load settings and then save them. If you can’t, then there is probably a COM issue between the PC radio and the PC.

Mission Planner Version 1.2.86
915 MHz
We did not purchase these ourselves. We inherited them from another senior design team. They did not come in either plastic cases or shrink wrap.

Ground module is in COM 3.
MP set to COM3 and 57600 baud.
APM is off.
Pressed Load Settings in MP.
Error: Failed to enter command mode

APM is on.
Both Air and Ground Mods have solid green LED
Pressed Load Settings
Failed to enter command mode

Pressing Upload Firmware in either test led to an error message saying
"Failed to identify Radio"
The spaces for the settings are left blank and I can’t manually change them.

The driver for COM Port is version which is the latest.

If the mods work with my smartphone, I’m assuming that this is a connection problem with the laptop. But I get the same error message when using other another computer. Plus, the driver is the latest version on both PCs.

Try doing a reset to default parameters.
If that does not work, then the ground unit might be bricked.
Since you inherited these radios from another group, are you sure that they are genuine 3DR radios and not clones? Some of the early clone radios did not work right out of the box.
You might also try communicating with the ground radio with the 3DR communication tool:
TCIII Developer

  1. Are 3DR and APM connected through USB at the same time, if so then remove usb cable and try again.
  2. Are you using the 3DR on a laptop or on a conventional PC? Laptop or tablet does not provide enough amperage for it to work in a stable mode - I had that problem when updating firmware of my APM.