Can’t load firmware

I tried to load firmware in my new PixHawh but can’t get the USB to link. I have tried three computers with the same results. I am beginning to think a defective unit.

When I plug in the USB I just get a continuous click, click and it does not show up on my computer. It’s like it’s truing to boot but can’t. I have tried several USB cables with the same results. When it clicks the PWR LESs on both sides flash when it clicks. I have tried with nothing plugged in and the same results.

Any ideas or do I need to call Tech Support Monday?

Have you tried APM Planner 2.0?

Yes I even tried uninstalling everything including the driver and reinstalling but nothing.

I think that the problem is more basic. The PixHawk is just not communicating with the USB port. Maybe the basic firmware that communicates with the USB is corrupt. Is there any to reload the boot loader?

I am beginning to think it’s a hardware issue because I don’t get a steady power LED. I even tried powering the PixHawk with a battery but Planner 1 or 2 can’t see it. I will call tech support tomorrow and see if I need to send it back.


Please ensure your USB port is capable of powering the Pixhawk or try using a powered USB port.