CAN ports do no detect GPS Here2 modules (dual gps in orange cube)

Hey there,

I want a system of dual GPS. I’m using two Here2 GPS modules, at first, I wanted to connect one of them to GPS1 port serie and the other to CAN1 in an Orange Cube . I used the correct cable 8/4 pin for each other. When I connect the cube to the Mission planner (the baud rate is correct) the module which is connected to GPS1 is well detected and performs correctly, but the one that is connected to CAN1 (or CAN2) does not work: the current arrives to it as it has lights on but the led color is rare “breathing” blue led light that I had never seen before (and the NFT_LED_TYPES is on 231 UAVCAN), here I leave a video of a guy who had a similar light color problem:

blue breathing leds problem

As I said, the current arrives but in the Mission Planner only one GPS es displayed (the one that is in GPS1). Here are the parameters that I set up:

CAN_P1_DRIVER: 1 (the GPS that is connected to CAN1 - I’ve tried also 0 and 2 but nothing happens)
GPS_TYPE: 1 (the one that is in GPS1)
GPS_TYPE2: 9 (the one that is in CAN1)
GPS_AUTO_SWITCH: 2 (because I want blending but there is no difference if I chose another)

The swich inside the Here2 is set to CAN mode for the one that is connected into CAN1. And I have tried to configurate CAN_P2_DRIVER and CAN_D2_PROTOCOL to use CAN2 insted of CAN1, thinking that maybe the port was the problem. Anyway, only the GPS1 port gps is detected and in the mission planner screen it should show 2 gps, even if one of them is not receiving signal.

Now, I try to connect both to CAN1 and CAN2. The parameter set up is the following:
CAN_P2_DRIVER: 2 (I’ve tried 1 also it does not work and neither the another if I change it to 2)

Switches of both modules are set on CAN mode but it is the same. Both of them show the blue breath light and the mission planner does not detect neither of them now.
Also, in GPS_AUTO_CONFIG I have tried all configurations 0,1,2 but neither of them works, the gps are not detected. I though It could be the cables but I changed them and the result is the same.
Do you have any idea which problem could be?

Thank you so much

For this use case to work, you have to assign different CAN adresses for each device.

About the previous configuration using both serial and CAN devices, no guess about it. I never tried something similar so I am afraid I am not able to help you.