Can not Upload APM:Plane Code Using Arduino IDE


I downloaded the latest APM: Plane 2.76 code and tried to add the sonar reading to it. I compiled the code using the Arduino IDE and uploaded it successfully to the APM 2.5, for the first time. When, I tried to upload it again, it gave me the following error:

[color=#FF0000]avrdude: verification error, first mismatch at byte 0x3c000
0x29 != 0x08
avrdude: verification error; content mismatch[/color]

I recompiled the original code (APM:Plane 2.76, without any personal modification), and tried to upload it, but it gave the same error.

I tried to compile and upload the ArduCopter code, and it compiled and upload successfully to the board, and for several times.

I don’t know what is the curse with the APM:Plane 2.76 code.

BTW, I tried the same procedure on two different APM boards, and it is giving the same error.

Can any one help me to debug this issue?


I assume that you are using the modified Ardupilot Arduino IDE:
TCIII Developer

I noticed something. If I go back to version 2.75, it works all successfully.

What is the possible problem here? Do I have to use specific version of Arduino IDE.

I am working on Mac OS, but also the same problem happens in Windows.

I am using the modified version of Arduino IDE, but still the error appears if I am using APM:Plane 2.76. But it doesn’t happen for 2.75.

Hey all,

Problem is solved. So for those who may ever come across this issue here is what I did.

I simply followed this guide, and it worked successfully. Also make sure that you have the latest code release.

The guide link: … rduino.pdf

Good luck!

Well I tried the link you gave yesterday and followed it to the letter and the code failed every verify attempt. Looking for a variable that wasn’t assigned??? I forget which one, but it was one of the AP_xxxxxx var’s