Can Not Calibrate Compass

I have a 3DR APM Ver 2.5.2 (I also have a Hextronic ublox LEA-6H GPS, but that is another issue since I haven’t got yhat far yet), and when I try to do “Live Calibration”, it does not log any sample data points, it registers “0” and gives a message of not enough sample points when the 60 seconds are up. I received this for Christmas and put it aside until I gathered the components to buld a second Tricopter (The one I have uses a KK2 board but I wanted more). I am at a loss as where to start the trouble shooting, ir do I just give in early and order an external compass?

Most probably you have some wires crossed. Triple check your wiring. SCL and SDA could be reversed. If power is reversed, you would have seen magic smoke by now.

Checked that mutliple times, after posting, I shifted my thinking and searched elsewhere on the web, and came up with a possible answer. I have to get my volt meter back, but i believe that i do not have the 3.3 volts to the mag. When i am able to check, I will post my findings.

I had a similar problem. I had just upgraded my 2.5 board to a 2.6 board and added the external compass/gps module. I was using a netbook with a short USB cable attached to the apm. It was a real pain trying to calibrate it. In my case I could usually get x and y within the ± 150 range. The Z axis would never come into the correct range.
I tried for days to get it to work. I watched videos on YouTube and asked for help on this group.

I ended up figuring out that if I held the hex on each axis for 15 seconds it worked like a charm. That was the only way to get 60 seconds worth of data. In hindsight, if I had purchased the telemetry modules, it would have been much easier to do the calibration without wires. One bay you can get the telemetry modules pretty cheap.

As I try to calibrate, I watch the countdown window and it continually shows “0” data points. I also just had an error message show up that stated that the mag could not be enabled. This is the first time this happened, but it just adds to my concern about the 3.3 volts. I now worry that I may not be able to use the external compass because it also uses the 3.3 volts (I think). Anyway, if it comes down to it, I have a very big hammer that will fix it for sure…

Sorry, not sure what I’m missing about the 3.3 volts. You don’t have 3.3? I guess you think it might be a fried regulator? They are pretty sensitive, don’t have a lot of capacity, although a measly compass shouldn’t overload it. But you never know, it could have gotten blown somehow.

You might try adding an external 3.3 volt supply in some empty corner of your setup. They are cheap, and robust, can be fed off of the balance cable of your LiPo, and there is always a need for solid 3.3.

You’re not at the hammer stage yet!

Okay, I borrowed a volt meter, and sure enough, I have no 3.3 volts, it measures “0” volts out of the regulator. The input to the reg is 4.89 volts, and this is the source voltage coming from my PC’s USB. There does not appear to be any darkening or discoloring of the regulator, so I am relucatant to believe it smoked, I just believe it isn’t working. It has been a while, but my background includes repairing consumer electronics, so I am not completely out in left field, My weakness is in the computing side of the APM (even though, I do tinker with computers, just not programming). I have been monitoring “DIY Drones” forum about issues some are having problems with 3.3 volts in their unit. No one mentioned unable to calibrate compass, so I missed it at first. … 44%3ATopic

I have ordered a replacement regulator from DigiKey, and will try that. After that who knows


Besides the 3.3V regulator issue, you should confirm you have an APM 2.5 or 2.6, even when the APM’s PCB has the label V2.5.2 on it, what determines the version is the presence of the compass (or magnetometer) on the board, if the board has the magnetometer that means it’s a 2.5, if not then it’s a 2.6, take a look to the attached picture. If you have an APM 2.6 and your GPS has not a built in compass like the 3DR uBlox GPS with Compass Kit then the whole system doesn’t have a compass and the calibration will fail and also you will get the initialization error in the terminal.

Okay, here is a picture of my module and the measurements I have taken.

The board is 2.5, so your system has a compass. The regulator should supply 3.3V to the compass (and other chips), so having 0V at the regulator output will cause problems with the compass and other sensors.

Thanks, that is what I figured, the bad thing is that I waited until I posted my problem that I changed my thinking and came to that conclusion. Sometimes it takes trying to explain it to someone else to light up the light bulb in my head. Thanks to everyone that responded, this was my first time to post (on this or any other forum), and the response was great. I will let everyone know the outcome when I get the regulator in from DigiKey and see if I can change it. In the mean time, I guess we can close this post or what ever is done, but I will lurking around following everyone else’s story and maybe I can get my skills up and can help some one in the future. Again thanks

Okay, I said i would let everyone know the outcome when I changed the 3.3 vdc regulator, and I changed it and everything works fine now. Mark this one solved and thanks for the help.

Thank you RogelioN. The pix you posted helped me a lot. I have an Arducopter module from 3DR that I could not calibrate the compass on. The board says it is a 2.5.2. But after seeing your pix I checked and it did not have a compass chip installed. I bought a 3DR Ublox GPS with compass kit and it all worked great. Thanks again. :slight_smile:

Glad I could help, That particular board has since “Bit The Dust”, and I have an APM 2.6 with the external compass and GPS. I just received this, and have not had time to get it all setup. My son presented me with one of the 3D Printer from XYZ, and that is where my time has been allocated lately. Hope you have as much fun as I have had with Tricopters, just can’t shake the old RC Plane thumbs when something happens and I need to make a fast move, back on the stick is not up, and that usually ends up with a crash.