Servers by jDrones

Camera Trigger Problem by Do_Digicam_Control

Hi, i’m a new user and I’m trying to perform my missions using a fixed wing as a aeromapper.
I’m confused about the “DO_DIGICAM_CONTROL” command in mission planner V1.3.33 because when i plan a mission by “Survey (grid)” method, the lines “do_digicam_control” appears with the first and the sixt field =1, and the fifth field (shutter cmd)=0.
With this command line the shutter does not work.
Instead if I manually put 1 in the fifth field of all mission “Do_Digicam_control” rows, and “0” in the first and sixt Field, then the shutter work perfectly. I doesn’t work with all fields ="0"
But if I insert a new row by click the button “Add below” and chose the command “Do_digicam_control”, then the command automatically appears with the field “Shutter cmd” = 1 and other fields =0
This behavior appears strange and it forces me to manually correct all rows “Do_digital_control”, but i Think this isn’t the right way to use this command.
Is there any solution to this problem?

Fabrizio

Hi Fabrizio,

The camera triggering in ArduPlane and copter does seem to be more complex than it should be. If you take look at this plane.ardupilot.com/wiki/common- … am_control

to see the details of this command. Param 5 is the command to trigger the shutter. Note that this command will only trigger the camera one time.

If you are doing a survey mission, you are probably better off using the do_set_cam_trigg_dist command. It will trigger the camera every x meters. You only need to insert this at the start of your mission. Insert another one at the end of the mission with the distance set to 0 to turn off camera triggering. Mission planner should at least insert the first one for you. See plane.ardupilot.com/wiki/common- … trigg_dist

Regards
James

Hi James, thank you for your replay.
I know the metod you described, but i need to use Do_Digicam_control because in case of wind the flight with only two waypoint at start and end of each lane of one tipical mapping mission is not enough accurate. Then i hope it will be solved the question as soon as possible.
Now i manually correct the fifth parameter in each row of the mission and the arduplane work perfectly, but if i perfprm a mission with many shots, this is too complex to do.

Fabrizio

Yesterday i tried to install an old firmaware (I changed the actual arduplane 3.4 with the firmware 3.22) and I surprise to discover then with this firmware version the command “Do_Digicam_Control” work fine also if i Put “1” the first and the Sixth parameter, or also evenif i put =0 all parameters.
Is there anyone wich can explain this strange behavior and suggest how to use the version 3.4 with “do_digicam_control” without editing the fifth parameter and put it = 1 in a mission planned by SURVEY_GRID function?
Thank You
Fabrizio

Dear Fabrizio! Thanks for the investigation. Hopefully this will solve our problem as well: do digicam control works fine with arduplane 3.3 but when upgrading to 3.5 it suddenly stops taking pictures. Even though trigger camera now works perfectly from mission planner! I do not know if this problem had been addressed by mission planner software updates or not?

Servers by jDrones