Calibrating OnBoard Compass issue error:99

I have the arduplane version 3.2.3 installed but have issues to calibrate the on board compass of my apm 2.5 board.

I get the error compass 1 error:99

Some guys mentioned the same issue already but I could not find any solution for this.

Any thoughts?

I dont know if you have the same problem that I did but I could not get mine to calibrate because I did not connect the GPS/Compass module to the APM once I connected it it worked fine. Does yours have an external compass?

I do have the APM 2.5 with onboard Compass.
My GPS Midule is without compass.
I have the issue also with connected GPS Module.
Nevertheless if the APM is armed it shows me the compass in mission planner and also reacts on turning the APM but not really correct.

Hi I have the same problem

Compass 1 erro: 99
Compass 2 erro: 99

APM 2.6 (3.2.1 Firmware)

External compass GPS NEO6N

No solution at this moment…

And you ?

I did not find a Solution for the 99 error. I bought a new external GPS with Compass and cut the Bridge on the Board to disable the onBoard compass. Now I have a Very strange result. I do get information during calibration of compass one. The result is that the compass reaction is extremely slow. Next to that the compass reacts if I move the external compass but also the APM board ???
Still not satisfied. At the moment I fly with disabled compass which works quite fine.