Building 3.2 branch from Git

Hello,

I’ve had some success adding mavlink commands and Aux servo outputs to the master branch… and flying my pixhawk quad with my build !. however, i ran into some snags and thought it would be better advised for me to play on the released 3.2 branch. Problem is I just can’t get it to build.

Can anyone point me to a guide/release-notes/build instructions specific to 3.2?

specifically the issues I am fighting with are:

  1. what branch/date of PX4Firmware and Nuttx to use with ArduCopter 3.2 ?

  2. if i pull master of PX4Firmware and Nuttx I errors with
    config_px4fmu-v2_APM.mk config_px4fmu-v1_APM.mk including these modules that i do not have
    #MODULES += systemcmds/auth
    #MODULES += modules/libtomfastmath
    #MODULES += modules/libtomcrypt
    the other make files mentions these in comments as unnecessary so i hacked them out.

  3. if I bypass 2) then i run into this problem
    make[3]: *** No rule to make target /Users/giovannirey/Documents/drones/pixhawk/source/px4/testbuild_32_clean/ardupilot/libraries/GCS_MAVLink/include/mavlink/v1.0/ardupilotmega/../common/./mavlink_msg_optical_flow_rad.h', needed byBuild.ArduCopter/ArduCopter.cpp.o’. Stop.


probably the right answer is just to get the right source code and make files from GIT. can anyone help me out a little?

thank you,
giovanni

I think the whole problem might be related to issue 1). You need to use the 3.2 Branch in the PX4Firmware and Nuttx repositories. When you change them, be sure to do a Make Clean and Make PX4-clean before trying to compile again.

thanks Rob,

I see now that the 3.2 branch in px4firmware is labeled plain as day. I am not sure why i couldn’t find it. perhaps i was accidentally looking at the px4/firmware tree instead of the diydrones/px4firmware.

got it.

Hello, I had the exact same question and I was using the wrong directories for NuttX and Firmware too. but now that it actually lets me build, it will run for a long time, seeming fine, the pop up with this

[color=#0000FF]px4/ardupilot/libraries/AP_GPS/AP_GPS_PX4.cpp:70:55: error: ‘struct vehicle_gps_position_s’ has no member named 'time_utc_usec’
compilation terminated due to -Wfatal-errors.
make[3]: *** [libraries/AP_GPS/AP_GPS_PX4.cpp.o] Error 1
make[2]: *** [/Users//Desktop/px4/PX4Firmware/Build/px4fmu-v1_APM.build//Users//Desktop/px4/ardupilot/module.pre.o] Error 2
make[1]: *** [/Users//Desktop/px4/PX4Firmware/Build/px4fmu-v1_APM.build/firmware.px4] Error 2
make: *** [px4-v1] Error 2[/color]

Can someone tell me what is wrong?

Thanks!

Nolan