Build failed after ' -w' command, attempting sitl with Linux

I’m very new to linux and trying to get software in the loop running, following the tutorial here:

I’m running Linux (Ubuntu) using a virtual machine (I have a mac), and I’ve worked through the installation steps provided in the tutorial above, but now trying to run the ‘ -w’ command from the ~/ardupilot/ArduPlane directory, after a “Cloning into ‘modules/PX4Firmware’…” step, I get “fatal: unable to connect to”.

Following this, a few more problems come up (like ‘git submodule update failed’, and ‘…/mk/ recipe for target;CHECK_MODULES’ failed’), but I think maybe these just stem from the initial failure to connect?

I previously had a problem running “git clone git://” with it failing to connect to github, but got around that by using https instead. If this current problem’s related to that, I’m not sure how to use the same workaround to get a command to work.

Any suggestions for things to try would be appreciated!

If it’s failing to connect to github using git protocol I’d guess you are behind a proxy. This is one of the options available for that:

1 Like

Hey there! This worked for me:

In the latest github Ardupilot branch the has been replaced with Python script

However I havent been able to get to work on Ubuntu for myself yet. I suspect I dont have all the required package dependecies installed.

I have just noticed that the wiki instructions for Windows and Linux now specify the python script. As this is obviously an ongoing development I suggest everyone makes sure they are using the latest versions.

@ecoharpo your comment here was a little misplaced; your problems are almost certainly not network related!

That being said - can you paste in the error you are getting?