Bootloader update warning

I’m currently using Copter 4.1.5 and today tried to update my heli to 4.2.0. The update failed with a warning message, “Error: No response from board”. The board is disconnected from MP, as instructed, but still plugged in to the USB.

So I then thought maybe I needed to update the bootloader first, but I’m put off by the warning message about it might brick my board :confused: What’s that all about, please? My board is an mRo R15 Pixracer.


The warning is scary but I have never heard of a board actually being bricked by this procedure.

I don’t think that this is the cause of the “No response from board” message though. The USB cable probably just needed to be disconnected/reconnected and/or something has grabbed hold of the COM port (maybe MP itself)

This is a good overview of the process. Thanks, Randy!

1 Like

Ok, thanks. Seems there’s no need to update my bootloader, so I’ll try again with the 4.1.5 → 4.2.0 Arducopter update this afternoon.

1 Like

Job done, though I’m not sure why! Thinking that perhaps a background Windows10 upgrade in progress might have messed things, I tried again just now without changing anything. Same result.

So then I closed MP, switched to a different USB port, and re-started MP. When I then connected my board it came up with the same COM port number, but changed the baud rate from 115200 to 9600. I then went to the Install Firmware page, disconnected the board using the button, and started the download – board still connected to the USB port. After MP had finished downloading the firmware, and was waiting for a reponse from the board, I unplugged and re-plugged the USB connector. It then immediately started installing 4.2.0.

I had tried that same sequence of operations yesterday, so maybe the problem was simply that the baud rate was too high.

1 Like

Hi @abenn1,

Great that you got it working. The baud rate shouldn’t matter when using a USB cable connected directly to the autopilot. It certainly matters if using a telemetry radio but not when using a USB cable.