BLheli32 ESC telemetry configured but not working. Help

I have a Pixracer and I’m trying to get the ESC telemetry working on it, but nothing I do will make it work. Passthrough works just fine, it passes the test just fine, but in logs the ESC messages don’t show up and in MP I get no data from the ESC. There are a couple threads about ESC telemetry and I’ve tried everything in them with absolutely no luck.

Autopilot is on V4.0.4
Test output:

10/20/2020 6:02:16 PM : ESC: Test PASSED
10/20/2020 6:02:16 PM : ESC: Prot 0 Good 0 Bad 0 0 0 0 x0
10/20/2020 6:02:16 PM : ESC: BL_ReadBuf 16 -> 19
10/20/2020 6:02:16 PM : ESC: BL_SendCMDSetAddress 0xEB00
10/20/2020 6:02:16 PM : ESC: BL_SendCMDSetAddress 0xEB00
10/20/2020 6:02:16 PM : ESC: BL_ReadBuf 256 -> 259
10/20/2020 6:02:16 PM : ESC: BL_SendCMDSetAddress 0x7C00
10/20/2020 6:02:16 PM : ESC: Interface type imARM_BLB
10/20/2020 6:02:16 PM : ESC: BL_ReadBuf 8 -> 9
10/20/2020 6:02:15 PM : Initialising APM
10/20/2020 6:02:15 PM : ESC: BL_ConnectEx 1/4 at 1
10/20/2020 6:02:15 PM : ESC: Running test on channel 1

Just checking for understanding - you have the ESC telemetry pin wired to a UART right? We don’t currently support bi-dir dshot.

That is correct. Tried both telemetry 1 and 2.

What ESCs do you have? Are you using Dshot protocol on your ESCs?

Post a parameter file for review.

Here you go

I am using this ESC from get fpv

Does the PixRacer recognize Dshot in the Banner message in Mission Planner on boot? As it shows here Rcout but on yours it would be Dshot 1-4 (or 6 depending on BRD parameters).

Connect to Serial port Rx pin?

I don’t see anything obviosly wrong in the parameters.

Connected to this port Rx for Serial 2?

Pixracer telem 2

I went over them as well and same conclusion, it all looks good. However it would be good as @dkemxr says, the banner message would really help…

If you are sending a PWM signal to the ESCs you will not get back any telemetry by default.


I did a dumb and cut off the edge of the screenshot but all the important data is there.

That does look right.

Can you post a pic of exactly how this is wired to your FC?

I think it does look right for a PixRacer (got plenty of those). No IOMCU.

OK, is it connected to the right port for Serial 2?

Is there a chance the baudrate or telemetry rate is set wrong? I haven’t changed them but there’s no documentation on what they should be. Has anyone gotten telemetry working on a pixracer before?

Set this to 10. 0 is no telemetry request.

It started at that. I was playing around with that earlier and forgot to change it back. Just changed it back and checked, still no telemetry.

Did you power cycle it after making the parameter change?

Yep. I at least know to do that.

I just hooked this up to a scope and it doesn’t look like it’s sending any data over the telemetry wire. When I set the SERVO_BLH_TEST is that data coming over the telemetry connection, or the pwm connection?