Big issue with APM 2.6 / calibrating compass

Dear community.

2 months ago, I bought my first apm 2.6.
After waiting some delivery time, I recieved it 2 weeks ago.
I bought the ArduPilot Mega 2.6 with the external compass.

After building my hexdacopter, I mounted all apm hardware.
I succesfull connected it, I have both link (USB and telemetry) working properly.

Now my big problem. After „live calibration“ of the compass, I always get the message „Log does not contain enough data ».

No problem I though, ask Google.
It looks like this is a well known problem.
I really tried everything.

I have no more ideas how to solve that problem.
Thats what I already tried:

  • reconnect all plugs.
  • initialize all ESC again
  • watched nearly all youtube vids how to calibrate a copter,
    tried it at least 30 times in all methods
  • reset the APM
  • changed place where I calibrate it
  • always used Rotation_Roll_180 and choosed external compass
  • simulated a flight with at least 30% throttle (armed the copter manually, drove with car
    while simulting a flight. Don’t ask how this looked like….)
  • after that, I tried to load the datas, same error message….
  • Reinstalled mission planer and the copter software.

Fact is:

  • Compass is working (USB and telemetry link)
  • GPS signal is found (blue LED is constantly bright)
  • Telemetry downlink works

There are people saying, that sometimes the Voltage regulator could get killed…
But all my sensors are working.

I really appreciate if somebody has another solution fort his problem.
I waited over a month to get that ardu and now I can’t use it…

Many thanks!


The heading in the HUD can change direction even if the compass is not working because the APM will use the Az gyro to obtain heading information.
Only rarely have I had a working compass fail the calibration test for not enough data and then a recalibration solved the problem. If repeated calibration attempts result in a not enough data messages, then there is the possibility that the compass is either defective or there is a communication problem between the compass and the APM.
I assume that you have installed the GPS/Compass module per these instructions: … ss-module/
If your installation appears to be correct, then I suggest that you use the CLI in the Terminal Tab to troubleshoot your problem: … apmcopter/
Following the Wiki instructions you can select the “test” function in the CLI and test the compass. If the compass is not functional you will get a message saying that the compass cannot be initialized.

Many thanks. I’ll try this at home!
I’ll let you know.


OK, seems my UBLOX has a problem…
results in CLI:

Mag Dec: 0.0000
Mag off: 0.0000, 0.0000, 0.0000
Motor comp: off

test compass:
Compass initialisation failed

hmmmm. send back to 3drobotics?

If you need to send it back contact

Before you do, check that the 4pin i2c cable is properly connected, and none of the pins are bent on the APM2.6 or the connection on the GPS/Compass module.


I will. The small connectors a a little crappy to remove. But I tried so many things, so this want be a problem anymore. :wink:

thx for your answer.

For information on how to correctly place/remove the connectors, please check this video:


Just for your info.
After recieving a replacement (thanks to 3dRobotics), the calibration was ended successful!
Maybe it’s a new software, but this time I can see how many datas the apm is recieving during calibration process.
I didn’t had that on the old / damaged one…