Battery low warning with Ardcopter 3.6 and 3.7 even if battery is good

Hi all,
I updated my skyviper’s firmware to one of the recent versions so that I could use external navigation system for controlling the drone indoors but after the drone takes off it continously flashes the error/warning that the battery level is low while it is actually not! Why is it so and what is the work around? Thanks in advance.

AC 3.6+ changed the Battery Parameter name

I tried to get in a PR to get the default.parm file for Skyviper updated for those builds, but it has never moved.

Anyways, you need to change these
Old parameters:

BATT_CRT_VOLT 3.43 <-- The SV default value
BATT_FS_CRT_ACT 2 <-- The SV default value

The reason it is dying so fast is the AC3.6+ default value for those failsafes is like 3.9V, which is higher than the SV battery capacity.

1 Like

Hey @lordneeko, I changed set BATT_CRT_VOLT to 3.43 and BATT_FS_CRT_ACT to 0 (because I dont want the drone to do anything when the battery failsafe is triggered) and I rebooted my drone, still I have the same issue!

That definitely should have fixed it. I had to do the same for mine.

I did these changes using QGroundControl. Is it okay?

I just turned off the battery monitor using mission planner and it doesn’t warn me anymore about this.

Should be fine. Confirm that it kept the value through a reboot though.


Yes it does! Thanks.

Don’t forget to check both the BATT_LOW_VOLT and the BATT_CRT_VOLT . By default on the SV, the BATT_LOW_VOLT was disabled I think. But it may be enabled within the AC default.

1 Like