Servers by jDrones

Ballence bot on pixracer


(Jdunkle) #1

I have a new ballence bot on pixracer with stepper motors working fairly well still a work in progress but have had an issue with the aux 7 pwm for its use. I have a 7 character. Tx with spectrum sat rx and all channels show on radio calibration but in basic parameters the option is not highlighted (blanked out). I have tried different versions. 3.5 dev and now 3.5 rc1 with the same affect. Not sure if its pixracer not supporting 7 channels. Any ideas would be great as I want to use the aux for arm disarm so I don’t have to use a telem. radio.

Jack


(rmackay9) #2

Jack,

The issue is just the parameter names have changed from 3.4.2 to 3.5. So if you move to the beta version of the Mission Planner it should work. Go to the Help screen, down at the bottom, “Check for Beta Updates”. If it doesn’t then it means we need to raise an issue for the MP here.


(Jdunkle) #3

Thanks for the quick reply I have not been able to get the aux ch. To work from the beginning. I have used 3.5 dev. And now 3.5 beta and no luck. I have function of 6 ch on my pixracer and it shows ch 7 on radio calls but no function in mission planner.


(Jdunkle) #4

Also saw did you mean beta ardurover or beta mission planner ?


(rmackay9) #5

Jack,

I meant beta Mission Planner but I’ve just checked and it needs to be updated to use the new RC7_OPTION parameter so I’ve created an issue. To be clear, this is a ground station display issue not a “flight code” issue. It’s possible to set the RC7_OPTION directly from Mission Planner’s Config / Tuning >> Full Parameter List or Full Parameter Tree screens.


(Jdunkle) #6

Thanks Randy I tried that in dev but will try again in your 3.5 beta. Also next week I want to post my testing on the stepper motors on my ballence bot and see if anybody else is working on this.


(iseries) #7

This looks interesting.
I currently have this unit which uses A4988 steppers: B-Robot EVO Kit

I also have a PixRacer unit on a quad right now but could re-purpose it to do this instead since I purchased some extra Nema 17 stepper motors and A4988 steppers.

The problem seems to be that the Ardupilot does not support stepper motors. I see from the picture you are using the Tic driver board set to RC input so it is doing the conversion.

The A4988 unit cost about $3.00 each and the Tic unit is about $20.00.

What I could do is use another microcontroller to convert the PWM into steps and see what I can get to work.

The unit is very quick using stepper motors compared to using servos.

I also have some continues rotating servos that I could also try and having a 3D printer helps a lot in making something work.

Mike

PS I have similar wheels but I 3D printed my own adapter to go from 5mm to 12mm hex.


(Jdunkle) #8

I finally have it close to running, I can drive it around sorta. There is a lot of tunning the normal pid and the tic motor driver you can set max speed,acceleration and dead zone. The nema 17 motors have adequate power. Still not sure what to do with auto mode as there are no encoders or feedback from the motors. Still working on acro mode as when I change to that mode it starts to osolate in the roll uncontrollable. I know there is a acro turn rate turning this down helps but seems like a pid issue but not sure were to tune this, maybe Randy you could chime in on this. Glad your looking into this in the end I think this will make a very smooth running machine.


(gmorph) #9

That looks awesome. Any chance of a video of it working? I gotta build one of these!

Thanks, Grant.


(Jdunkle) #10

Yes I’ll get a video put together next week when I get home, out if town at the moment and post it. Also I’m putting together a list of the parts I used and my setup.
Jack