Servers by jDrones

Bad or No Terrain Data


I’m pretty new to the Ardupilot scene. I recently purchased a Pixhawk and am working on setting it up. I’ve configured most of it but when I connect MAVlink in Mission Planner I’m getting a “Bad or No Terrain Data” error. Looking at the status tab in Mission Planner it shows ter_pend = 336, ter_load = 0, ter_alt = 0, etc. When I override the arming checks and arm the controller I also see no logs saved to the SD card when I disarm and take a look.

I’ve formatted the SD card as FAT32 and verified I can read and write to it with a PC, so I’m not sure where to go from here. Any help on where to go from here is greatly appreciated, thanks!

Are you planning to use terrain follow?

If not, Disable the params TERRAIN_ENABLE and TERRAIN_FOLLOW

I’ve read the wiki on terrain following, but I too am pretty new on Ardupilot.
Disabling the parameters you give will get rid of the warnings, but I AM planning to use terrain following to maintain a fixed relative altitude above terrain, and the section on terrain following didn’t help. Where to use those commants? Does not MP normally access the data online on request from the FC?
A few words about how I can get terrain data onto my card, please?.

I haven’t much experience in terrain follow, but the one time i did try it, it worked smoothly. MP was connected to the internet, and the terrain data got uploaded to the pixhawk sd card via telemetry.

I have exactly the same problem and cannot resolve it. I’ve reloaded Mission Planner, the latest firmware, formatted the SD card, tried my other Pixhawk but the Terrain will not load, just stays pending.

I got this error a few times.


there used to be an issue that the needed “terrain” directory would not be created automatically on the SD card of the APM causing all kinds of issues…Please check if you can find this folder on the SD card. If it is not there, manually create it at the root directory and rerun your tests.

1 Like

That was the Fix. Thanks mate.

1 Like
Servers by jDrones