Bad crash using 3.2 firmware update


I am using Pixhawk and just recently updated the firmware to 3.2.
I was changing flight modes with the phone, testing posHold (which never worked), alt hold, loiter and circle modes, all of them worked perfectly while the quad was alive.

Just before the crash, I started to hear the battery voltage alarm.
At that moment the quad was set in “circle” mode. I wanted to take control of it so I can land it manually. I changed from circle to loiter and as soon as I was ready to set stabilize mode and take control of it, the motors just stopped and the quad felt down like a rock and now it’s completely destroyed.

Could you please take a look at the logs to see what happened, is it a bug or is it something I did wrong?

Thanks for your help.



Using the auto analysis the logs state that you had high GPS errors… It reports a Max HDOP of 6.62 with 1 satellite. The actual event/failsafe was FLT_MODE GCS CRASH GPS_GLITCH

The log also reports the logs truncated at an altitude of 8.10m and suggests that it may have been a brownout.


Hi Mike,

So, it seems that having 2 GPS devices doesn’t help very much.
Too bad the quad is FUBAR so I could say that there were lose cables or anything.

The lesson for the next quad will be “flight modes other than stabilize and acro” are forbiden, pixhawk will become a very expensive multiwii. :slight_smile:

I have never had a problem like this because those were the only modes I use to fly, I just felt curious about the other flight modes today and this happened.

Thank you for the help.



Well, I’m far from an expert on log analysis and am only using the automated tools so take what I wrote lightly. The Pixhawk may very well have been using 2 GPS units but the analysis tool is only reporting on one of them. We’d really need to graph things out a bit to see what really happened.


Logs also show you trying to select flight mode8 which is no longer supported by ac3.2.
I’m assuming you didn’t set up ac3.2 with a beta version of mission planner which is needed (at least until today) to set up ac3.2 properly.
Would also explain why PosHold never worked as it could not be set as a flight mode option without using beta mission planner.

Flight mode 8 is Position, very different to PosHold and not supported by AC3.2

Looks to me that the problem isn’t AC3.2 but the other software you were using in conjunction with it not being up to date enough to fully support 3.2

Man, you can’t expect your drone to fly on an empty battery…
you just emptied your battery and experienced a simple but destructive low battery event.
Please take a look at your log, and look at the log CURR->Volt, CURR->Curr and CURR->CurrTot

You have set a low battery voltage of 10.5 on a 4S battery… :open_mouth: :open_mouth: :open_mouth:
A 4S battery should never go under 12V.
So if you heard a battery alarm, it meant it did have no more juice. But really no more, not like you have time to climb 15 meters in RTL and expect it to land safely…
Which it did not, in fact there is an RTL just before the crash.

Your flight controller has just enough reserve power to log the last 250ms where your current consumption goes from 29Ah to 6Ah and your at 8 meters high, that means your motors are slowly dying due to no more battery power…
Been there. :smiley:

If you have consumed 4625mAh, so you either emptied a 4500mAh battery or have an old and not more reliable 5000mAh battery…

Please take time to correctly set the battery alarm and set the correct failsafe for your setup.
Then eventually complain about the software :smiley:


I reviewed the logs. You drained your battery below 3.0V/cell, so the cause of the crash is obvious.

Your GPS performance seems not terrible to me. #Sats is about 8 on 1, 11 on the other. There’s a few dropouts, but never goes below 5. HDOP is around 2 generally, but does go up to 4 on one of the GPS. It took both of them quite a while to get a lock though.

Which GPS units are you using?