Servers by jDrones

Bad AHRS fault, is the pixhawk faulty?

pixhawk
(Colin) #28

Thank you so much. I can only calibrate compass 2 and it points in the correct direction but gives error “Bad Compass Health” and I can’t ARM. this I expect is because the external compass is faulty. I have two replacements coming from banggood, so hopefully they will solve all my problems.

(Colin) #29

Do I need the battery connected to calibrate?
I thought I would try calibrating using The Wizard and I can’t get past “Missing BATT_CAPACITY param” something is wrong then I get “Failed to set battery size, check input”.
Could this be the problem??
When I see calibrating demo’s on youtube they don’t show any battery attached.

(David Boulanger) #30

I’m not sure but try putting in the BATT_CAPACITY in. What ever mAh it is. I have never used the wizard

(Colin) #31

Have done that, still no success.

(Jeff) #32

I believe the batt capacity param is part if the batt fail safe setup. It wouldn’t effect the compass calibration, but you will need to fix it for the fc to arm. In fact setting up the pixhawk largely consists of clearing up each of the many warning messages you’ll see (at least on my pixhawk it was like that). So, at least you’re making progress

(Dave) #33

I wouldn’t use the Wizard either. What version of Ardurover are you on?

(Colin) #34

I am waiting for new GPS module to arrive.

(ahmet omer ozgen) #35

Hi, I had the same problem with neo 6m compass.

It can be many things and replacing it may not solve it. Here are the probabilities

  1. wrong orientation : sometimes the chip is 45 degrees angled on yaw, or 180 degrees on roll or even both. And you may be physically installing the module in a wrong way
  2. i2c faults: i2c may have inconsistencies with compasses. Back up your parameters to computer. Reset all of your parameters in FC. Wait 5 seconds. Plug the power off. Wait 12 seconds. Power on.

Try to calibrate now. Then you can restore the params again

  1. same sensors used in neo 8m and pixhawk causing issues because its on i2c channel. I have no idea if this claim is true but there are some reports.

  2. no Voltage regulator in the module causing the issue (3.3V 5V differences for apm/pixhawk)

  3. if your gps works (df13 connections are different for apm and pixhawk) but no compass on hardware id it’s probably dead.

I didn’t sleep tonight and googled the similar issue.

It has got nothing to the with EMF at this point.

Some suggests removing all the cables except gps/compass (without gps connection compass can’t be feed). Usb connection to your MP and try calibration now.

I hope you can solve this issue.

(Colin) #36

Hi,

Have you seen this https://github.com/iNavFlight/inav/issues/2619
These guys are cutting a chip out of the module and replacing it with a couple of wires.
They are using Inav. I don’t know enough to say if it would be a suitable mod for pixhawk and Mission Planner.

(ahmet omer ozgen) #37

Well it appears to be driver issue im their case.

I think the reason is mostly the orientation or the pixhawk. Have you tried the re orientation?
Also check this topic

(ahmet omer ozgen) #38

I ve soled my issue.

roll180 was the fix for me!

you may try roll 180i yaw 180 in order

don’t forget that each time you change orient, you must re calibrate accels then compass.

No compass variance error no stuck at 33 percent! nice!

I knew it wasn’t a HW error!

(Colin) #39

I have solved my problems also.
I have taken a gps module off an old drone that I know is good and it calibrates.
So the problem is with the cheap crappy Chinese gps modules.
Grrrrrrrr!!!

1 Like
(ahmet omer ozgen) #40

Actually they have no issues. The problem stems from orientation. They don’t print what side is the mag is soldered. So we don’t change the orientation. It’s mostly 180 roll or 180 yaw.

(Jeff) #41

Great to hear that you were able to find a solution!

(ahmet omer ozgen) #42

thanks!

if the mag calibration stucks it means there is a disorientation. changing roll 180 or yaw 180 would probably solve it!

If i knew tho , i would never buy a cheap fake unit!. gps sucks

(Colin) #43

How does one know that the GPS module is faulty or fake?
When banggood sell it you expect that it at least works. The good news is I have found the problem and banggood have refunded me.
I want to thank everyone for their support and advise, it has been a great help.
Thank you

1 Like
(ahmet omer ozgen) #44

connect it via serial usb to pc. use ublox software. there are detailed guides. if you see that it is not flashable. it is 100 percent fake

(Colin) #45

Hi again,

I received a new pixhawk 2.4.8 and the GPS module, and I am still having trouble calibrating them with mission planner.

I am getting Bad AHRS error and Error compass variance.

With the pixhawk and GPS arrows pointing North (real compass heading), mission planner is showing 22.5 degrees north north east.
The only way I have found to clear the error is to have the GPS arrow pointing 22.5 degrees north north west and the pixhawk arrow pointing north.

I am concerned there is something wrong. From all the reading I have done, both arrows should be aligned.
Is the GPS module faulty or is this what you have to do sometimes ??

hdop 0.9, 13 Sats

(ahmet omer ozgen) #46

Hi.

Use the external compass only. Can you do a full compass calibration with success?

Try the roll 180 if fails or yaw180.

It’s a random factor with Chinese fake modules.

Btw if your edges are white in your px4, some guy in YouTube claims that screws are magnetizing the IMU and compass.

I didn’t tested it yet. And if i unscrew them i don’t know how will i replace or demagnetize them.

(Colin) #47

Hi,
I re calibrated with external compass only (no.1). I had both pixhawk and GPS arrows pointing in the same north direction.
The result was, mission planner shows 15 degees east of North.
So I just turn the GPS module west untill it’s pointing north in mission planner.
Now it seems calibrated. When I point the pixhawk + GPS north, west, south, and east, mission planner shows its pointing in the correct direction.
I don’t know if this is the correct way to calibrate but it seems to be working. Any advise or comments would appreciate.