Bad AHRS and Large Compass Deviation

My University has a large 650 Octocopter using a black cube with a Kore carrier board and a Here 2 for GPS. The quad had not flown in 6+ months and after getting ready to try and fly it again, it stated Bad AHRS and we tried doing a compass calibration and it still complained. We had strong SAT’s so we flew it anyway, cautiously, however it ended up toilet bowling into the ground and caused quite a bit of damage. After rebuilding the same as it was before, I expected maybe that incidence was just a bad day so we tried flying it again. After taking off and hovering maybe 3 feet off the ground, the telemetry showed a large compass deviation (90 degrees) and it started trying to yaw itself a bit in stabilized mode and started acting overall twitchy. After fearing what happened last time, I landed it before anything bad happened. Since then we have tried several calibrations, including the motor interference calibration as I thought that’s what it was. Yet, still right when the arming button is pressed it shows Bad AHRS. This quad has dozens of hours on it in the exact configuration (besides rebuilding exactly as it was) and I see no reason for it to have suddenly started giving us issues. Also had a spare cube so threw that on as well and it gives the exact same results. Another thing we have tried is turning one compass off and the other on, and I can’t tell which one is the cube compass and which one is in the Here 2 but one of them causes it to fly terribly. Attached is the telemetry file. 2021-04-14 13-14-25.bin (526.1 KB)

Both of those compass device ID’s show they are are on the SPI bus which is internal. An external compass is not shown. Check this on the Setup>Mandatory Hardware>HWID screen in Mission Planner.

1 Like

See if that allows the external compass to show up, and then disable the internal compass(es)

1 Like

Thank you for letting me know. Now I wonder why the Here 2 compass is not showing in the hardware. Do you have any ideas as to why it would not appear on the hardware list? It works fine as a GPS still and all the wires are undamaged.

Not offhand. You do you have a COMPASS_TYPEMASK of 32 which disables the LIS3MDL compass driver but I didn’t think the Here 2, which has a ICM20948 IMU I think, had that compass.

Update, I found a Here original GPS module and have replaced the Here 2 with the Here 1. Once I replaced the GPS, the compass list immediately populated with a new compass. I tried removing the mask for the Here 2, as Dave suggested, however the Here 2 compass never appeared under any hardware list. I’m thinking my Here 2 compass may be dead. Hoping to do a test flight next week and will see if adding the replacement GPS will help the condition at all.

Did you try the boot delay?

I did try to do the boot delay, however, it still did not recognize the compass inside of the Here 2. I think my Here 2 compass might be damaged or something, as it does not ever show up under any hardware list, but when I connect a Here 1, it immediately pops

Could it be the SCA and SDA pins are reversed? Pin 4 and 5

All of the wiring is the included wiring for the Here, and none of it ever changed from when the vehicle had dozens of hours on it until now. I would consider that if the wiring had all been changed but this is the same configuration is has been in for a long time.