Auxiliary switch to activate a rangefinder don't work

I’m trying to use an auxiliary switch to activate a rangefinder, but it doesn’t work. Even if the channel to which it is associated (ch12) reaches 892 pwm when it is low, the rangefinder always seems to be active. How can I switch it off?

arducopter 4.0.5

This dicates the use of the rangefinder data, not whether its results are
being used.

Given the use of filters on the data coming from the rangefinder, we can’t
stop taking measurements.


Hi Peter,
the behavior of my quad is identical with both high and low switches. Unfortunately I use a VL53L1X lidar that works well indoors but badly outdoors. This is why I would like to exclude it with a switch when I am outdoors.


Hello @Alberto_Ds,
Where you able to resolve this issue ? I’m currently trying to disable rangefinder for certain time, but it is still sending the data.

hello, as explained by Peter the rangefinder still transmits data, regardless of the status of the aux channel. I did not continue the tests because that rangefinder did not work correctly or the fw version 4.0.5 did not manage it correctly. I have tried with another rangefinder (TFluna) on a rover and in that case the bypass with aux works

Thank you for the information @Alberto_Ds