Aux outputs help needed

Hi all

Don’t know if I have read the instructions correctly or if I am trying to do something that is not possible, but

I have Arducopter loaded to my Pixhawk and use a 10 channel radio system connected via PPM.

I use channels upto 8 without issue but cannot get channels 9 & 10 to work, I am trying to get them to work the first 2 Aux pins sets for servo control but cannot get any response. I can map channels below 8 and they do work but everything I have tried for 9 & 10 has failed.

Starting to think I have just miss understood the instructions and that ardupilot does not support more than 8 channels.

Can anyone with more knowledge confirm that 8 channels is the limit or should I be able to use more if they are available.

If I should be able to get channels 9 & 10 to map to the Aux pins, how do I do it.

Thanks for any help with this


A little more information on what you have. Model of receiver and transmitter might help.


I am using the Turnigy i10 Transmitter with the Turnigy iA10 Receiver.

Receiver is in PPM mode


Can anyone please confirm that if using a radio system with more than 8 channels that all channels above 8 are usable when using the Pixhawk/Mission Planner Combination

Or is there a 8 channel limit as it appears.

Someone of knowledge in these thing must be able to answer this question.


Yes, I am using an X8R receiver and have it configured for 12 channels at this point.

What firmware are you using?


I am using v3.6 of Arduplane and v3.3.3 of Aducopter

Could you explain how you set your Aux channels up to work



Hi Mike

In Arduplane I have found the following

RC09 is supposed to control AUX1
RC10 is supposed to control AUX2
RC11 is supposed to control AUX3
RC12 is supposed to control AUX4

If for example I put the setting for RC09 as 56 AUX1 will be controlled by the Radios Channel 6, puting at 57 gives control to channel 7, and 58 gives control to 8

So going on the 59 should give control to ch9 and 60 should give control to ch10

Unfortunately no figure I enter will give control to channel 9 & 10. are you doing it in a different way to me and if so how different.



I don’t know about 33 and up as these most be new features in 3.4 dev. If you set it to 1 it will do RC Pass through so what every is coming in on channel 9 will be passed through to Aux1. RC10 = 1 it will control Aux2.


That is the way it should work but not with mine

I followed these instructions

And still got nothing. I have 4 Pixhawks and get nothing on all of them.

Don’t know if its of any help but peram file attached, perhaps it will be more obvious what I am doing wrong

BRD_PWM_COUNT set to 4 This is supposed to enable Aux 1 to 4 for servo use
RC9_FUNCTION set to 1 This is supposed to enable Aux 1 to Pass-through Mode
RC10FUNCTION set to 1 This is supposed to enable Aux 2 to Pass-through Mode

Mission Planner Aducopter Perams.param (8.4 KB)

I just tried this with an Oscilloscope connect to the port so I could see what the PWM output looked like. RC9_FUNCTION does control AUX1. I set it to passthrou which is attached to a switch on my radio and I could see the PWM change on the scope. I did have to push the safety switch to enable it. This may not be necessary with 3.3 and I think this changed on 3.4 dev.

I originally had it set to control a gimbal witch is option 7 and had a pot connected to channel 6 and that also was working to control the PWM on AUX1.

Your param file looks right so it must be the radio or receiver not sending the signal.


Thanks for confirming that (Must get myself a scope) at least now I know I am not going nuts.

Will play with a few other radio TX RX options I have to see if I get any more joy.

I built the DSO138 scope unit for $25. So far great investment. The parts along I think are worth more than that.


Just ordered one, will take 2 or 3 weeks to get here.

Just read an article in one of our UK modelling mags were the author said that PPM has a limit of 8 channels, is that correct, is that why I can’t get more than 8 to work with my Pixhawk.


My receiver has 16 channels using SBUS. X8R. All of them work. Don’t know if PPM has that issue.


I can confirme this issue.
No Aux_Out does work. Even with Pass_Thru nor designed as Gimbal Tilt in the Gimbal Configuration of MP.
I can read the inputs moving in MP -FlightData Windows “Tuning” but the ch9out to ch12out remains at Zero.
BRD_PWM_COUNT = 4, RX Taranis X8R via SBUS. I checked various Type of Gimbals in the menu.
Pixhawk V2 from 3DR
The connected gimbal does not work, but connected to a RX it works as it should.