Servers by jDrones

Autotune never completes

I’m trying to autotune a quadcopter one axes at a time but it never completes before the battery gets low enough to cause the copter to RTL.I will include a log where I attempted the roll axes.
Setup is 500 quad frame,3105 720kv motors, 12.45 carbon fiber props, 5200mha battery.Thanks

6 minute fly time is very thin, either the 3s is small, or prop-motor combination is suboptimal. Plus you flown almost three minutes before started autotune. No surprise it did not finished.
You can go as low as 3.3-3.35 volt per cell if you can land quickly at the battery failsafe. But I would redesign for longer flight time.

4S power of equivalent weight might get you there.

I should have posted the log from my second attempt, on that try autotune run for a little over 7 minutes on the roll axes and still didn’t complete. But maybe that still isn’t long enough.I just remember in the past when I would do an Autotune it never took so long per axes but that was on different copters. I have a couple 4s battery’s on order when I get those ill give it another try.
Thanks for replying.

Also check your vibrations. The more vibrations you have the longer autotune seems to take per axis

Have you got a .bin log you can link to?

Yes here is a link to a bin file for a flight I run autotune on.https://www.dropbox.com/s/xzrydl3bpbwio6n/2020-03-23%2019-19-53.zip?dl=0

I’d highly recommend getting the current monitoring working, it’s not recorded in logs, and do a Compass/Motor calibration.
Vibrations look good.
Apply these params and retry autotune. It will be less aggressive and maybe that will allow it to complete quicker. 12 inch props are getting a bit ambitious with 3cell, but maybe it could work.

ACRO_YAW_P,2.80
ATC_ACCEL_P_MAX,93800
ATC_ACCEL_R_MAX,93800
ATC_ACCEL_Y_MAX,25200
ATC_RAT_PIT_FILTD,18.00
ATC_RAT_PIT_FILTE,0.00
ATC_RAT_PIT_FILTT,18.00
ATC_RAT_RLL_FILTD,18.00
ATC_RAT_RLL_FILTE,0.00
ATC_RAT_RLL_FILTT,18.00
ATC_RAT_YAW_FILTD,0.00
ATC_RAT_YAW_FILTE,2.00
ATC_RAT_YAW_FILTT,18.00
ATC_THR_MIX_MAN,0.10
AUTOTUNE_AGGR,0.05
BATT_ARM_VOLT,11.00
BATT_CRT_VOLT,10.50
BATT_LOW_VOLT,10.80
BATT_FS_CRT_ACT,1
BATT_FS_LOW_ACT,2
INS_ACCEL_FILTER,20.00
INS_GYRO_FILTER,36.00
MOT_BAT_VOLT_MAX,12.60
MOT_BAT_VOLT_MIN,9.90
MOT_THST_EXPO,0.67
PSC_ACCZ_I,0.62
PSC_ACCZ_P,0.31

You can copy/paste to notepad and save-as a .param file then easily apply it with MissionPlanner.
If that goes OK, set:
AUTOTUNE_AGGR,0.075
and try again.

You’ve got a conservative angle max, which suits filming and probably your relatively large, slow props, so maybe try this too:
ATC_INPUT_TC,0.2 -> or up to 0.3
This should give nice smooth RC control

If you change to 4 cell, change these:
BATT_ARM_VOLT,14.70
BATT_CRT_VOLT,14.00
BATT_LOW_VOLT,14.40
MOT_BAT_VOLT_MAX,16.80
MOT_BAT_VOLT_MIN,13.20

You can execute autotune for a single axis at a time. It means a flight for pitch, a flight for row, and aflight fo yaw.

After checking the vibrations and overall prop/batt/prop compliance, you may change the parameter AUTOTUNE_AXES.

You may check it out:
https://ardupilot.org/copter/docs/autotune.html
https://ardupilot.org/copter/docs/parameters.html#autotune-axes

Thank You Shawn…I copied the parameters changes you suggested and was able to do an autotune on all three axes and now have a nice flying copter.
Thanks Again, Alan

Servers by jDrones