Autotune failed / Pixracer / overpowered

Has anyone tried turning off oneshot and then auto-tuning to see if that’s the issue?

On my copter it works with oneshot125 enabled. So this seems not to be related.

1 Like

It’s OK, we should move on. Regarding the threshold of noise: before 3DR left ArduPilot there were people paid to do forum support; now that they left there is no one paid to do it. That means that anyone from the team looking at the forum is doing it in their free time - and sometimes that free time has to go to code development (not only programming but issue list maintenance, pull request review, etc.). I can tell you that last week I had about 20 tabs opened in my browser with things I needed to look at - about 10 were from the forum. I wanted to do it earlier but I just didn’t have the time.

The team, and me personally, really appreciate all the testing that our users do. But to make our life easier I’m asking that all of you share the link to your logs with the problematic autotunes over here, so that we can address it in the same thread.

Thank you.

Francisco: we can little contribute to mantain this forum sometimes when we open a topic and then discover that already exist erasing it and moving the question to the other, updating the log, etc (as my autotune post that is duplicate with this and log is out of date now) but I couldn’t find the way to remove it, It’s any choice to do it? thank’s

Hi Leonard,
I guess my problem is : MOT_THST_HOVER, 0.1654751
However, the copter flies perfectly with the latest master (V3.4-dev (0eac5a5c), Jul 4, 2016) and manual tuning based on the one autotune that returned reasonable values on the pitch axis. If you are interested in a log please let me know.
I tried autotune with MOT_PWM_TYPE, 2 again. It starts and works as expexted but again the resulting values are too low.

What I suggest to cala, wicked1, and lorbass is to

  • save the PIDs of your 3.3 copter,
  • install plane or rover to clear all Params
  • install the latest master
  • compare the Params and update only the really relevant ones
  • run inital setup again
  • manual tune it until your copter flies,
  • try autotune.

Best regards,

1 Like

As far as I’m aware there is no way for a regular user to remove a post. Even I don’t have moderator rights, although, given the time I’m spending here, I will probably ask for those. The good thing about this forum system is that the more and more you interact with the community the more rights you get: you can look user levels at

But if you open a topic and then realize that there was already one where you could have posted, the best thing to do is:

  • repost in the other topic
  • edit yours with a link to the other topic. If you put the link right at the beginning of your post and explain that discussion should go there I think that’s enough
1 Like

Thank’s for clarificate Fransisco and the tip.

Hi all,

Sorry for the delay. I have been swamped.

For those of you having trouble with a poor autotune result increase AUTOTUNE_AGGR to 0.1. This is generally caused by too much noise increasing this number addresses that.

If you have a 250 quad then you will need to set this:

For those that are having trouble getting autotune to start. Make sure your throttle is in the dead band. The other issue I have seen is caused by increased rate gyro noise stopping autotune from running (hard mounting may be causing this).

I am pretty much finished all the changes for the 3.4 release now so I am trying to kick into flight test mode. I will be loading 3.4 onto about 8 different copters and testing autotune so I hope to have more info for you soon.

Sorry again for the slow response but both Randy and I are struggling with time to get to everything. We are almost there now (I hope).

Thanks for all your support.

1 Like

Could everybody with Autotune issues post a link to the logs with a quick description of what went wrong. This saves me trying to find where you described the problem.



Thank’s Leonard I’m going to give a test, I change INS Gyro from 20 to 40 and AUTOTUNE_MIN; the rest is as I had that don’t work like that, I have a doubt AT_MIN_D says out of range with 0.0005, no problem?
Im going to report results, my PR is hard mounted and IMU2 disabled.

Ok, I did my task,
I change yaw filter to 40 too.
First log is from Roll, no wind but a little space so many corrections, copter is a 270 racer with 2350 kv and hard mounted Pixracer (AUAV)
I switch to autotune and copter begin with short movements as did before I disabled IMU2 (because it’s looks more noisy) but now I allow to finish all the process, many little movements and at the end, longer movements, reverse than older fw on bigger cuads, when finish, I land and disarm saving autotune, change batt and test pitch over a bigger place but a breeze appears and I had to correct many times too and couldn’t finish because batt finish first so I landed and disarm saving values if they are usefull to analize. I didn’t have more batt and light to yaw and test results.

Comparing params looks like this

pitch didn’t save nothing, if I can, tomorrow try again.

Hi Cala,
That is definitely a bad tune.
First up, the Yaw filter should stay at 5.

This looks like there is too much rate noise. I have a direct mounted copter and need to have a look at this to track down what is happening.

The only suggestion I can make at this point is to drop the Roll and Pitch filter to 20 and try again.

There is no point doing a pitch tune until your roll tune looks good.

I apologise for the frustration here, this is the first time we have been dealing with hard mounted IMU’s.

Thank’s Leonard, I go that way and try again, I did some test with 20 and 5 in the past but, time to time one motor didn’t arm, really I don’t know why, I calibrate esc. I try again, see what happens and share results again.
Many thank’s

Looks what happens when I change filters, first arm one motor don’t spin, second arm the four spin but not stabilize to take off, third time the same; perhaps It’s better to soft mount?
Sorry I’m a rock with this :flushed:


Hi Leonard,
I tried another Autotune again today with the latest master from today with Paul’s EKF enhancements (8793c75) and 200g payload. It failed as usual. This time I used the settings you suggested above for 250 quads. Since it is bigger (Motor to motor: 400mm; AUW: ~1.35 kg; Battery: 4S; Motor: 920KV) it might be the wrong direction. What happed for the first time and what others reported here as well as, is that there were periods where nothing happend. I guess the settings tested by Autotune during theses periods were out of range?!

You find the log at:
I then adjusted the settings (based from the one correct pitch tune) again a little manually. A log of a short flight with these is at:

Can it be a combination of regenerative braking and an overpowerd system?

Thanks and cheers,

PS: the PixRacer is soft mounted:

well, I also use ESCs with regenerative braking on my bigger hexas without any autotune problem. So I guess that’s not the case. I can’t imagine it it oneshot, since the one pitch autotune worked. So I still guess it is the power of the system and maybe some inital autotune settings.

Hi Thorsten,

Are you able to get a very fast SD card to do some high data rate logging for me?

I am seeing the same things in your logs as I am seeing in others. I had put this down to a direct mounting problem but it may be something else.

If you have a fast SD card could you set the pid logging to: 1048573 and go for a flight and send me a link to the log?



No problem, it should be fast enough . K-Index is too high today for save flying… So hopefully tomorrow - or later today.
Do you need an autotune flight or just a short normal one?

Best regards,


You find the log at
There are vibration peaks at 50Hz, 100Hz and 200Hz in the ACC data.

Best regards,

Hi Thorsten,
I think the gyro noise is pretty high but I will have to do some comparisons to my other copters. I hope I can get this done over the weekend.