Auto Flaps - how to setup

Hello everyone!

I’m working on setting up auto flaps for landing and takeoff on my aircraft. I followed this:, but I can’t seem to get the flaps to move on my benchtop when I put the Pixhawk into FBW-B mode.
I can move the flaps from the remote control (switch on channel 6).
I have set the RC pins to mode 3 (as it says) for auto flaps, as well as everything else in the manual.
I have also tried setting an auto takeoff waypoint and the Take Off flap parameter to 100%, yet the flaps still don’t move when I start the mission.

Any ideas?
Thanks guys!