ARMING_CHECK value not working for rangefinder prearm check

Hi everyone, I have a quad with here2 GPS (disabled, only for compass and baro), and rangefinders for proximity avoidance (4 cardinal & up) from walls and ceiling (we are not worried about floor, as it is uneven, and we want to follow a barometric altitude. We intend to fly in AltHold (per object avoidance docs, horizontal object avoidance works only in AltHold and Loiter, and due to our lack of gps, we can’t use loiter).
I have:
EK2_GPS_TYPE set to 3 for no GPS
EK2_ALT_SOURCE set to 0 for barometer alt
I have the ARMING_CHECK set to 28662 (0110 1111 1111 0110) to disable GPS lock, GPS config, and Rangefinder as there is no downward rangefinder to pass the “check” and obviously no gps. When powered on, I still receive the “PreArm: Check Rangefinder” message.

Has anyone had a similar experience or some sage advice?