Arming Causes ESC to enter calibration mode

I’m putting together an x8 and I’ve run into an interesting problem. First, I can’t do the all at once calibration with pixhawk. My Opto ESC’s keep beeping as if they aren’t getting a signal.

The larger problem is that they enter calibration mode once Pixhawk is armed. I get the constant beeping of no signal when I first start everything up. Then, once I arm Pixhawk I get the confirmation beeps that the new end points have been set. However not all the end points are the same and some motors still beep as if they aren’t getting a signal.

Any ideas as to why this would happen?

I’m running 8 KDE 55A ESC’s and my receiver is an x8r plugged into the rc port of the pixhawk using the sbus out of the receiver. I’ve tried both the latest stable and beta firmwares.

Have you done your RC calibration already?

If the all-at-once ESC calibration isn’t working on those ESCs, you can always do the regular one-at-at-time method with your RC receiver.

I’ve done the RC Calibration. I’ve also tried raising RC3_MIN to 1122. That seemed to solve some similar problems people were having with the DJI ESC’s.

I can do the one at a time calibration, but once I arm pixhawk the ESC’s enter calibration mode and get messed up. Also, not all of them get armed. Some of them keep beeping like they’re looking for a signal. The ones that do get armed usually don’t start spinning until around 50% throttle.

So I’ve been in contact with KDE, and the tones I’m hearing are just the arming tones. However I still can’t get all of the motors to arm.

If I arm Pixhawk, 3 of the motors arm. As I push the throttle to 100% 3 other ESC’s arm (around 50% throttle). I still have 2 motors that won’t arm. The 3 motors that armed at 50% throttle also turn off below 50% throttle.

All of the ESC’s/motors operate normally if they’re plugged directly into the receiver, so I think that the problem is with Pixhawk. Maybe my outputs are broken somehow? Are there any settings that would cause all the outputs to behave differently?

Unfortunately KDE ESC’s have some sync issues with the pixhawk and there is no known workaround yet.

Is there still an issue with KDE ESC’s and Pixhawk? According to this page it can be accounted for:

Can you confirm?


Just in case it is useful to others, this is no longer an issue. The problem has to do with the control loop isolation on the Pixhawk hardware, and the solution is simple.