ARM- -> (SAFE) Pixhawk

Hi everyone,

Fairly new to the community, but I’m usually pretty good at being able to diagnose or follow other peoples mistakes/solutions. I’m like a deer in headlights right now though.

I have a quad copter with Pixhawk 2.4.8. It’s one that I grabbed off the shelf at my companies spare parts shelf to play with. I formatted the SD card, updated the bootloader, placed firmware on the board and everything was great. Landing gear, RC, GPS all worked fine. Armed the copter many times, spun the motors up- everything worked, only problem was I didn’t have props, so I couldn’t take off.

Props finally came in, and when I went to arm the copter, nothing happened. Hooked it up to MP and now whenever I arm the copter, the copter ARMS, then I get a red (SAFE) annunciator at the bottom of the HUD, and I get an audible low altitude warning. Motors do not spin and then the drone DISARMS about 5 seconds later.

What I’ve done:

  • I’ve verified my FS_THR_VALUE 975 is below my RC calibrated Throttle min 982 PWM.
  • I tried to calibrate the ESC’s, but I can’t figure out how to bypass the safety switch (because I don’t have one). Do my PARAM settings influence this? I have hardware safety switch disabled. Is this even potentially a ESC calibration issue?
  • Downloaded and installed new firmware. I was a little unsure which platform was correct for me the first time around, but I discovered that FMUV3 was what I wanted. It installed fine and I reconfigured all my parameters that I had done before to set up Flight modes, servos etc.

I’m still not able to get the motors to spin and I always get a (SAFE) warning. I haven’t made any manual changes that I believe would create this issue. Maybe the default PARAM settings are causing me grief?


BIN file-!AhwZoouBIvblhLs1VDTwwlMMY2Re_w?e=vdPXX6

Nothing in that flight log. Post your parameter file.

Sorry about that dave.

Param file

It’s enabled. Set BRD_SAFETYENABLE to 0 and restart.

Also, it looks like most of the parameters are at default. You wouldn’t want to make your 1st flight set that way. After connecting to Mission Planner hit Alt>A for the Initial Tuning Parameters plug-in. Enter the values as prompted and make those changes. Also, make sure you have done the Motor Test in Mission Planner to confirm proper motor order and direction.

Sorry Dave, I’m a bit of a hack.

I think I uploaded the wrong file, I have correctly disabled this param throughout my troubleshooting and I get continuous motor beeping.!AhwZoouBIvblhLtyy7zlOZberaYgew?e=lW3rGC

I have it at 0 now and I’ll await feedback.

Thanks for the tip on the tuning, I would have gone full donkey otherwise.

You will need to post a link to the video you uploaded to a cloud site. This is true for Flight Log files also if the contain anything… But probably don’t need a video just to hear some motors beeping because the ESC is not getting a throttle signal.

Fixed it. Was an ESC calibration issue.