Ardurover setup documentation

I am trying to reinstall an ardurover after more than a year of not using it. Back then there was an excellent wiki documentation site explaining the first time setup, particularly about how to assign channels on your radio for throttle, steering and which Pixhawk servo outputs to connect physically to the ESC and steering of the vehicle.
The current wiki is a catastrophy and this precise information is gone. I can’t find it.
Has anyone taken a backup copy of the old wiki for Ardurover (I’d be interested too to get it for the other vehicles) ?


Hi Hugues,
Are you using an APM2.x or a Pixhawk?
Try here for the APM2.x
Even though this rover wiring diagram here is for the APM2.x, it will work for the Pixhawk.
You can find skid steering information here.

Thx for this good old diagram. Much clearer than current wiki. Why has it been taken away ?
Anyway, I tried everything I could and cannot have a basic working ardurover setup:
-I have skid steering output =1
-On my taranis radio, I have setup Channel 1 as steering channel, and Channel 3 as throttle channel
(i also tried alternatively to setup channel 2 as throttle channel)
-I use a pixhawk with PPMSum
-On the Sabertooth, I have S1 going to the left motors and S2 going the right track motors
-When I watch in mission planner the servo output produced by Pixhawk, I see only servo 1 changing.
I do not understand what’s wrong. Any ideas ?

What are your RCMAP_X values?
I believe that the ArduRover firmware is expecting the Pitch channel to be for forward/reverse speed control and the Roll channel to be for right/left steering.

I have taken the following pictures of what happens:
RCMAP params are at default values:

Skid steer param is set to one (tank style vehicle):

With no stick input I get the following IN /OUT channels on mission planner status screen:

With full pitch (throttle input), I get a correct Ch3In at max, but I only get Ch1Out to increase. Ch3Out remains at neutral:

With full roll (steering input), I get a correct Ch1In at max, but I only get Ch1Out to increase. Ch3Out remains at neutral:

Is skid steering broken in the lateste Ardurover release then or do I do something wrong still in the parameters ? (param file attached)HugRover.param (7.5 KB)

Thx for your help

1 Like

I will ask Grant Morphett to take a look at your discussion thread.

thx, much appreciated.

Hi, are you using Pixhawk or apm 2.x? I have a problem like yours. I have had this problem with pixhawk.

It is a Pixhawk board but the problem was identified by Grant (Ardurover dev) as being a bug in the current 3.0 release. He’s going to correct the firmware in the newt release or sub-release.

thanks for information…

The new beta release is out - please test and let us know how you go.
Thanks, Grant.

I try to setup a bit different Wild Thumper 6WD but with the same problem. Maybe anybody can help.

Wild Thumber 6WD
T`Rex Controller (in RC Mode, auto mixing)
Turnigy 9x, PPM-Encoder
Pixhawk with Firmware 3.0.0 / also tried out 3.0.1(Beta)

Without Pixhawk it works.

I tried out all the same like Hugues. 1=Steering, 3=Throttle or throttle=2 makes no difference. Arming is possible but the motors are not running. I can see at CH3in the stick movements but Ch3out is remaining always at around 1500. (my neutral trim setting). I have disabled for testing all checks incl. the safty switch. Skid steering is disabled because of the mixed signal from the controller. But I tried out to set in/out to on/off on/on off/on. The controller should beep 3 times if it gets a RC signal. I think that is the problem - no RC signal from the Pixhawk even after arming it. But why? Cables checked and the optional setting for min pwm when disarmed is aktive. A test with Graupner Mz24 and sum signal makes no difference. No idea what to do next.

Any ideas? Hope somebody can help. Thanks, Tom

Why do you have the T Rex Controller in the auto mixing mode?

for no special reason, auto mixing is part of the rcmode and worked well in a short test without the Pixhawk. I suppose that the Pixhawk treat it like a signal from a “normal” esc /car with 1 motor. I am wrong with that?
Regards, Tom

If you are using skid steering with the Pixhawk, then the Pixhawk will do the mixing and the motor ESC should be setup as two independent motor controllers (right side/left side) without mixing.

Hello, sorry for continuing old thread, i have similar problem with PWM output on pixhawk Rover 3.2. I actually can not get any signal out. To me it looks related to version as it works normally on 3.12 with same settings. I connect ch3 an ch1 to sabretooth. The mission planner shows nothing on servo output page when on 3.2 When on 3.12 it shows green bars on all channels, but interesting: min, max and trim values are greyed out at 800, while in full parameter list values are different. Thanks fo any help,

Hi my friends
I have the problem with the ardurover 3.2.3
I want set the skid steer, but in the servo output the vale start from 1500 and go to 1900. This is correct for go forward but not go backward.
In the esc section I set normal.
My rover use the l298n driver for the motor at 12v.
The l298n have need 2 pin for pwm and 4 pin for the logic ports. I can use the arduino for all pin but for this reason i need dead the value from 1100 to 1900.
Pls help me