Servers by jDrones

ArduRover Pixhawk Servo Problem - Help!


(Juan Jimenez) #1

Hi,
First I want to thank you all for putting this forum together. This weekend I was able to set up an APM 2.6 working correctly on an existing rc car. Then I decided to upgrade the APM to a Pixhawk however the steering is not responding.

I have connected
RC channel 1 to PPM Channel 1
RC Channel 2 to PPM Channel 3
RC Channel 5 to PPM Channel 8

The Servo was connected to Channel 1 ( Steering) of the Pixhawk main output and;
the ESC (with red cable removed) was connected to Channel 3 (Throttle) of the Pixhawk main output.

The throttle works fine but there is not steering. I switched the cables in Pixhawk main output and the steering still does not work.

I have tried with two different Pixhawk units and installed firmware versions 2.4, 2.5 and 3.0 and still no steering.

Is there anything that I need to change in the parameters configuration?

As I mentioned above, the steering and Throttle work fine with the APM 2.6

Thanks in advance for your help.

Juan


(Thomas J Coyle III) #2

@Juan,
What are your RCMAP_X parameters?
Regards,
TCIII AVD


(Juan Jimenez) #3

Thomas,

These are the parameters

RCMAP_PITCH 2
RCMAP_ROLL 1
RCMAP_ THROTTLE 3
RCMAP_YAW 4

Thanks for your help.

Juan


(gmorph) #4

Could you please attach a .BIN or .tlog file when the issue is occurring and I will have a look. Also please double check your wiring - you have the plugs around the correct way etc.
Thanks, Grant.


(David Boulanger) #5

How are you powering the steering servo or output rail on the pixhawk?

Regards,

David R. Boulanger


(Juan Jimenez) #6

Thanks all for your help.

I was powering the Pixhawk with a 3dr power module (5 v). Once I removed the power module and power the unit with the car ESC (6.03 v) the steering started working. therefore, I have resolved the steering problem.

Could I keep the both powers ( power module and direct connection to RC car ESC) so I can monitor the battery with the power module?

Is it safe for the Pixhawk to be powered at 6.03 v using Rc car ESC?

Thanks again for all your help.

Juan


(David Boulanger) #7

Use the power module for the Pixhawk and power the servo rail with the BEC in your ESC. I’ve powered my Pixhawk servo rail with a BEC set at 5.7 volts for a long time with no problems and no Zener Diode. The power module only powers the Pixhawk and not the output rail.

Regards,
David R. Boulanger


(Thomas J Coyle III) #8

@Juanpa,
I have had Pixhawk equipped Rovers where the Pixhawk servo output bus was powered by a motor ESC that was putting out 6 vdc. During that period I had several Rover runaways.
The solution was to power the steering servo directly from the motor ESC and not power the Pixhawk servo output power bus rail. The Pixhawk servo output power bus rail is supposed to be able to take an ESC power input of over 10 vdc, but the two Rover runaways proved otherwise.
Regards,
TCIII AVD