Servers by jDrones

Ardurover mission in reverse


(Dries Rondelez) #1

Hi all,

My rover does the mission in reverse, manual everything is ok and in mission planner i also see it moving in reverse…

Is this a parameter?


(Linus) #2

Hi Dries,

i think there was some discussion about doing missions and following reverse wp path but i am pretty sure it is not a feature in apmrover2 yet. Did you go through the full parameter list ? there is good documentation about parameters so if it is a parameter you should be able to find it.

http://ardupilot.org/rover/docs/parameters.html


(gmorph) #3

There is a MAV_CMD_DO_SET_REVERSE which will make the rover go into reverse. More likely your setup isn’t quite right. Try STEERING mode and see what happens. That uses the same code to drive the rover as the AUTO code so you can see if you have the rover setup correctly.

If it still doesn’t work please attach a log file.

Thanks, Grant


(Dries Rondelez) #4

I managed to solve the problem.
I’ve originally connected on motor + to + & - to - and the other motor + to - & - to + on the ESC

Now I’ve changed both motors + to +. I’ve changed the throttle to reverse in mission planner.

Now everything is ok.
Is there a way to make the rover stay at a waypoint? On the water the wind makes it drift away?
THX


(gmorph) #5

You can set a parameter to drive the boat back to the waypoint should it drift off but it doesn’t do “clever” station keeping.

Thanks, Grant.


(Dries Rondelez) #6

ok, which is the parameter? thx :slight_smile:


(gmorph) #7

Sorry they are MAV commands - not parameters.

DO_SET_REVERSE is the command to tell a rover to drive in reverse.

MAV_CMD_NAV_LOITER_TIME sets the time to loiter at a waypoint.

Thanks, Grant.