ArduPlane problems on Beaglebone Blue


I followed the documentation to install and configure my Beaglebone Blue for ArduPlane, but it looks like I must have missed something:

  • When I run the latest ardupilot code built from git, I get the following:

05681812840901MS4525: no sensor found
004257132128561004777832388911005681812840901004257132128561004777832388911005681812840901004257132128561004257132128561004777832388911004257132128561004777832388911004257132128561004777832388911004257132128561004777832388911PANIC: AP_Baro::read unsuccessful for more than 500ms in AP_Baro::calibrate [2]

I configured using the “linux” board, as there was no specific beaglebone blue target given by “waf list_boards”

RCOutputAioPRU.cpp:SIGBUS error gernerated

Where have I gone wrong?


Addendum to the above: the correct build target for Beaglebone Blue is ‘blue’; I rebuilt arduplane for that target, and now get the same error as the binary dist:

RCOutputAioPRU.cpp:SIGBUS error gernerated

Any help appreciated!

For what it’s worth, I have since tried the ‘bbbmini’ build target, with the same error.

Kernel is 4.9.105-ti-rt-r113 SMP PREEMPT RT armv7l; I do have the following uncommented in /boot/uEnv.txt as well:


This is printed to dmesg when the above error is given:

[ 149.098461] Unhandled fault: external abort on non-linefetch (0x1818) at 0xb6f08000
[ 149.098468] pgd = da848000
[ 149.098481] [b6f08000] *pgd=9c60f831, *pte=4a324343, *ppte=4a324833