Arduplan servo output problem/question [SOLVED]

Hi all,

I installed Arduplane 3.9.1 on my Omnibus F4 V3 flight controller and tried to setup my Wing Wing Z-84 Elevon Plane. I followed the setup procedure and in FBWA everything works as expected. In MANUAL my servo’s react strange to RC input. When I pitch up the servo twitches up and down and ends in pitch up position. When I pitch down the samen happens.
Furthermore when I watch the servo output screen in Mission Planner after a pitch up on my transmitter the output servo signal doesn’t return to 1500. After a pitch down it does. See attached screenshots. The first shows servo output after pitch down and stick returned to center. The second shows servo output after pitch up and stick returned to center.



Can anyone help me solve my problem?

Best regards,

Jan Willem

Hi Jan,
pls make sure that no mixers in rc are activ and maybe you could post the logfile of the situation …
for now that is too few information to get into it …

Thanks for your reply,

I’ve attached a screenshot of my elevator channel input and output and a short log file.
Hope you can help.

Best regards,

Jan Willem

9 1-1-1980 01-00-00.bin (368 KB)

The problem is your RC2_MAX and RC2_MIN parameters. You have:

  • RC2_MIN 1486
  • RC2_MAX 1487
  • RC2_TRIM 1500

Change them to this:

  • RC2_MIN 1000
  • RC2_MAX 2000

or just re-run RC calibration.
Cheers, Tridge

Tridge, thanks, that solved my problem!
Don’t know how I missed that?

Best regards,

Jan Willem