Servers by jDrones

Arducopter on Small Quadcopter


(DorsetFlyer) #1

I have been trying without success to use ArduCopter on a 250 mm size quadcopter. It’s actually a bit “dead cat”, 200 mm across the props from side to side and 155 mm from front to back.

I’ve build several quads of sizes between 450 mm and 650 mm and they all fly well on the default settings. I realise that the settings have to be quite a lot lower for a small quad but I still cannot get it to fly without developing violent oscillations, particularly in pitch. I’ve tried settings that others appear to have used successfully but they don’t work for me. Here’s what I used on the latest flight (crash).

The flight controller is a Radiolink miniPix on an anti-vibration mount and running ArduCopter 3.5.5. The quad weighs 540g, and the motors are Emax MT1806 2280 kV with 3-bladed 5 inch propellers.


(S) #2

This question gets asked a lot, and probably will more and more… I wonder if there’s a way to set up a default set of parameters for small copters, just as a starting point?

Try changing your filters to these settings:
INS_GYRO_FILTER,80
ATC_RAT_PIT_FILT,40
ATC_RAT_RLL_FILT,40

You should unlock roll and pitch, as I’m sure they will be different on that geometry frame.

Here’s an old thread on diyd from Leonard about how to set them up… Mostly still relevant.

Here are my PID’s after an autotune this weekend.
250 size copter. 6x3x2 props, so they aren’t nearly as aggressive as your props.


(S) #3

My copter flies OK with those settings, but severely wobbles on descent. I’ve looked up all I can about it on arducotper based forums, and everyone either says that’s normal or to decrease PID’s.
BUT, in betaflight, it’s not normal, and can be tuned out… And it usually involves increasing PID’s to better deal w/ the dirty air under the props.

SO, while I do have a flyable copter, it’s not great, and I don’t really know where to go from here.
If anyone has more experience manually tuning arducopter to get ideal performance, let me know how you tuned out the wobbles on fast turns/descent, etc.


(DorsetFlyer) #4

Thanks for the advice Wicked1. I’ll try something much closer to your
settings although I’m a bit nervous about the Stabilise P’s of 18. I might
try 10 for a start. I did have the filters set to half of you values but
I’ll set them the same as yours.

I should add that the quad doesn’t oscillate badly in Stabilised mode. It’s
when in Position Hold or Auto that it gets going. I can fly an Auto mission
but only at very low speed (2 m/s) in little wind but even then a minor
gust will start it pitching badly.


(S) #5

Yes, try 10 or maybe 12 for the stabilize p’s. AutoTune is known to set them too high, and I didn’t manually adjust after my last tune.
I’ve not noticed many problems in auto mode… It’s not completely smooth… Often has a little jerk as it repositions towards the next waypoint. But flying to the next one is smooth. Descending is always shaky.


(S) #6

Dorset, how’s your tuning going?

I was wrong about auto modes being OK… Today I was flying in stab, and everything was good. Little wobbles after going fast, etc, but not bad.
Then switched to loiter, and it was very wobbly. It rocks back and forth after every reposition.

I think we need to tune the far right column in “Extended Tuning”, but am not positive. What’s now labeled “position xy” and “velocity xy”. That’s what I’ll start with.


(DorsetFlyer) #7

Wicked, I haven’t had a chance to fly because of the weather. I had tried
reducing the parameters in the right hand column because they seem to
control how aggressively the quad is sent towards its desired position
(either to follow a path or to hold position against the wind).

I’m guessing that Position XY_P determines how fast it needs to go to get
back on station and Velocity XY_P and Velocity XY_I determine how much
acceleration (tilt) is needed to build up that speed. But I might be wrong
about this.

Anyway, I found that reducing Position XY_P from 1.0 to 0.7 made things
much worse. Reducing Velocity XY_P to 0.5 and Velocity XY_I to 0.25 seemed
to improve things a bit but it was still very unstable.

Now I’m putting my hopes on increasing Stabilised Roll and Pitch up to 10
or more and see what that does. I’ll let you know how I get on.


(S) #8

Thanks. Sometimes it’s difficult to know whether it needs higher or lower PID’s…
I kept lowering mine originally, because a lot of people w/ 250 size quads have VERY powerful motors and 4s+ batteries, and they do indeed need low PID’s. But mine is 3s and I use a low pitch prop, and when I was using PID’s as low as some, I had bad wobbles… It couldn’t correct itself. So, in my case, my PID’s are a little higher and it’s flying better.
It’s still mostly a mystery to me :). I can, and have a decent tune and flyable copter, but I’m really struggling to get it perfect. Both too high and too low PID’s seem to have similar symptoms. And there’s a small range of good… Not like betaflight where the range of good goes from about 1/2 to about double of the default PID’s.


(DorsetFlyer) #9

I tried Stabilise Roll and Pitch at 10, in stabilised mode, and got bad oscillations. Maybe there is an optimum between 5 and 10, but I think I had better try Auto Tune next when we get some calm conditions. I’ve been nervous of doing it but I shall have to give it a go.