Arducopter 4.0.7 unable to arm

I’m new to Arducopter, and have it installed on a Pixhawk 2.4.8. I’ve gradually worked through the setup steps in Mission Planner 1.3.70, and have got rid of all the error messages on the Flight Data screen, but I’m unable to arm the copter. I long-press the arming button on the copter, and its red light goes steady, but the main LED either stays solid greenish-white (I guess that’s meant to be white) or goes flashing green. Other LEDs on the Pixhawk are two solid green ‘PWR’ and one flashing blue ‘ACT’.

I’ve done all the calibrations, am able to the the motor tests in Mission Planner, and have a solid GPS fix. Any suggestions what I’ve missed in either the configuration or the arming routine, please?

Hi Allen,
That button is the safety switch. Arming is normally done with full right ruder or via the ground control software.
Best regards,


Ahhh. Too late now, so I’ll try the full right rudder tomorrow. Does it have to be configured to act like that, or is that the default?

Thanks Maaarten

That is the default.

Thanks guys, it’s working as it should :slight_smile:

Now I’ve just got to figure out why motor #4 is not responding to transmitter control or to Mission Planner’s motor test. I’ve checked continuity of its signal and power connections so, apart from the possibility that the ESC’s gone faulty on me (I’ll check with a servo tester later), is there anything I might have done in Ardupilot that could disable a single motor?

As for arming, I use OpenTX so I hope to be able to program my usual ‘Motor disable’ switch to send the necessary 5-second arming signal from the rudder channel, so it’ll be the same as all my other copter and fixed-wing models.

Hi Allen,

As for myself, I am also a newbie in ardupilot, but I really like the spirit on this platform where especially the developers are doing a great job together with a lot of volunteers. That’s why I try to assist as well.

Arming can also be done with a switch on the transmitter. There is a special parameter to activate this feature.

As for the motor issue, please enable prearm logging and post the .bin file here in the forum so the specialists can take a look at it.

Best regards,


It’s certainly a whole new learning curve compared with iNav and Betaflight that I’ve got on my other rotors. A quick Google for “prearm logging” so far only reveals many instances of it not working correctly with Ardupilot v4, but I’ll look deeper and report back if I manage to get a log.

With the failed motor, when I armed the copter I got a solid green LED and five of the motors started turning slowly, but then it disarmed itself after about 15 seconds, presumably because it had detected the problem with the other motor.

No problem with disarmed logging. But in the meantime post your parameter file. It can often help diagnose a problem.

Thanks for that. Other things getting in the way today, so I’ll not be able to report back for a couple of days.

OK, I’ve set LOG_DISARMED to 1 so that I get a log starting at power-up. I’ve powered up my transmitter, then powered the Pixhawk (having previously warmed it up so I would get a quick GPS fix), then pressed the safety switch, then armed it with full right rudder. Solid green light, and all motors except #4 rotate slowly. After about 10 seconds the Pixhawk disarms itself, with green light flashing, so I then disconnected power.

I followed the instructions re. downloading logs, but I’ve then got a problem: The log file is .log and I can’t find how to convert it to .bin to post here. EDIT: It showed no file extension in File Manager, so I didn’t recognised it. But not needed now, as my problem is solved.

EDIT: I’ve solved my initial problem: I just realised my ESCs are DSHOT, and my calibration was done in ONESHOT mode. After I recalibrated just now in DSHOT150 mode, all motors are running. Dunno why the other 5 were seemingly running okay before.

There should be a .bin file there also.

You don’t have to calibrate when using Dhot.

Thanks Dave. I’ve found the .bin file now – it didn’t have a suffix “.bin” when I viewed it in File Explorer, so I missed it.

I don’t know what version of Dshot my ESCs are, so I just set it to 150 and it went through some kind of sequence which I thought was calibration. Anyway, it works, I almost got off the ground a few minutes ago in my back garden. Not enought space to risk a flight.

I did have one other issue though: During my brief test it was obvious the ‘elevator’ was operating in reverse. I’ve checked again in Radio Calibration and the pitch monitor goes in the same direction as the Tx stick, so if I reverse it in the Tx it’s going to go the wrong way in Mission Planner. Is this something I should be reversing in Mission Planner, rather than in the Tx?

No, reversing in the Tx is the right way.

Thanks Dave. Now that I’ve got the basics working, I hope I won’t need to ask so many questions :wink: